• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GW399LXUS06 Whirlpool Range - Oven Preheat taking too long.

Status
Not open for further replies.

Jingell

Premium Member
Joined
Nov 29, 2020
Messages
5
Location
Toronto
Model Number
GW399LXUS06
Brand
Whirlpool
Age
1-5 years
Gas range BAKE pre heat taking over an hour to get up to temp.
Broiler working, convection working a little better than bake but not great.
I checked that temp probe not hitting wall, and I calibrated the oven as suggested in the manual. Also did self cleaning.
Any suggestions? We wondered if we should remove the shield on the floor of the oven to clean the ports?
Any advice would be appreciated.
Thank you,
Joanne

Added model number
 
Last edited by a moderator:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,587
Location
McMullen Valley, Arizona
Hi Joanne,

W10432289A is not the model number, that's a part number. The model number will start with two or three letters first, like GS or WFE or WFG, etc.

Click here: Appliance Parts

Then you will see a link that says: How to find a model number.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,587
Location
McMullen Valley, Arizona
Thanks Joanne!

When you turn the oven on, open the oven door and look down at the bottom and see if its glowing orange, it should glow orange for about 45-60 seconds then you should hear the gas ignite. If the gas doesn't ignite within that 45-60 seconds, then your igniter glow bar is going bad causing this issue your having now.

Here's the oven igniter for your model you can order(Video Included):
74007498 Oven Ignitor


Let us know what you find.

Jake
 

Jingell

Premium Member
Joined
Nov 29, 2020
Messages
5
Location
Toronto
Thanks Jake. I will check this out as you recommend tonight. If this is the problem is this something that my husband and I can safely replace ourselves ?

Thank you,
Joanne
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,587
Location
McMullen Valley, Arizona
Yes Joanne,

This video shows you how to replace it:


Yes, keep us posted.

Jake
 

Jingell

Premium Member
Joined
Nov 29, 2020
Messages
5
Location
Toronto
Hi Jake,
The part did start glowing red within a minute but the gas didn't ignite for about 6 minutes. We'll order the part and install. Hopefully that will do the trick.
Thanks for your help !
Joanne
 

Attachments

  • 20201130_200915.jpg
    20201130_200915.jpg
    362.1 KB · Views: 50
  • 20201130_200736.jpg
    20201130_200736.jpg
    229.6 KB · Views: 51

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,587
Location
McMullen Valley, Arizona
Yes Joanne, 6 minutes is way too long, the new igniter will fix it.:)

Keep us posted.

Jake
 

Jingell

Premium Member
Joined
Nov 29, 2020
Messages
5
Location
Toronto
Jake,
Sending a big THANK YOU for your advice on fixing our oven ! We waited for the part, it finally arrived, installed it, and we're back in business ! Wishing you and yours a Happy New Year !
Thanks again,
Joanne
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,587
Location
McMullen Valley, Arizona
Excellent Joanne, glad to hear the new oven ignitor fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top