• Please note, some of the links on our site are affiliate links (Learn More)

FIXED HSM25GFRFSA Hotpoint side by side refrigerator dispenser issue.

Status
Not open for further replies.

iam4uf

member
Joined
Oct 12, 2012
Messages
13
Location
United States
Model Number
HSM25GFRFSA
Brand
Hotpoint
Age
More than 10 years
Hi, I have a Hotpoint Refrigerator Model # HSM25GFRFSA. Sometime when I press the ice/water/crushed ice buttons on the dispenser it doesn't work. There are lights on it and I can here a click when I press it in, but nothing comes out. If I keep pressing it over and over it will finally work and I can get ice/water.

Anyone have any ideas what this could be.

Thanks in advance.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
You mean when you press your glass on the dispenser paddle? Or the buttons on the dispenser display board?

If the dispenser paddle, ohm test the dispenser switch. Watch this video: Two Terminal Switch Testing

Here's the dispenser switch for your model:
WR23X10783 Dispenser Switch


There is a HOW TO video in the part link that shows you how to access it.

Make sure you unplug or turn the breaker off to your refrigerator first.

Let us know what you find.

Jake
 

iam4uf

member
Joined
Oct 12, 2012
Messages
13
Location
United States
when I press the glass on the dispenser paddle, I here a click and nothing happens. There are lights on the display. If I keep pressing the dispenser paddle over and over it will finally work.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
Ok, then I'd ohm test the dispenser switch first.

Jake
 

iam4uf

member
Joined
Oct 12, 2012
Messages
13
Location
United States
OK, replaced the switch, same exact issue. When I press the glass on the dispenser paddle, nothing happens. If I hit the crushed and then the cubed button a couple times it starts working. Sometimes it take 10 minutes other times 3 minutes.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
I didn't say to replace the dispenser switch, I said ohm test it first.:)

Many years ago we had a issue with the main board located on the back of the refrigerator causing this problem.

Here's the main board for your model:
Main Control Board WR55X10942P


Jake
 

iam4uf

member
Joined
Oct 12, 2012
Messages
13
Location
United States
Just thought to update. The issue was the main board in the back of the fridge. I replaced the main board and all works fine.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
Excellent, glad to hear the new main board fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top