• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Ice/Water Dispenser stopped working; Dispenser Light stays on

Kath

Member
Joined
Jan 4, 2012
Messages
1
Location
San Diego
Model Number
MSD2456GE
Brand
Maytag
Age
6-10 years
Have Maytag Plus side-by-side with in-door dispenser (#MSD2456GE). Filled glass with ice and water then tried to fill another glass. Dispenser light began to flash. Pushed ice & water buttons again and light stopped flashing but will not turn off and dispenser will not work. Have tried the lock button and the light button. Neither has any effect on the light or the ice/water function. What shall I try now?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,119
Location
McMullen Valley, Arizona

MMcK

Premium Member
Joined
Sep 3, 2011
Messages
2
Location
Texas Gulf Coast
Me Too. Maytag Water/Ice Dispenser Doesn't Work

Sounds like the same thing with my dispenser. Have an '06 Maytag MFI2568AES. The dispenser began to stop working, then start again, then finally quit altogether. Lights did the same thing as below.
Have you replaced the board and did it work? I think I'll try that too.

I am now having problems with cooling in the fridge and freezer quitting. Both units have quit several times now. I have been able to unplug it and plug it back in to get the compressor to come back on. But, it happens about once a week now. Front display didn't read correct temps until I reset (unplugged) the fridge. Coils are clean.
Also, sounds electronic.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,981
Location
Murray, Utah 84107, United States
Check to see if both fans are working. The evaporator fan is in the freezer section and the condenser fan is by the compressor. Make sure the condenser coils are clean and air flow across them is not restricted. See if the compressor is running. Look for frost on the evaporator cover (freezer section back wall) indicating a possible defrost issue. Use your hand to feel for any frost or ice on the evaporator cover. I have a feeling once your cooling issue is solved so will your dispenser problem be fixed.
 

MMcK

Premium Member
Joined
Sep 3, 2011
Messages
2
Location
Texas Gulf Coast
Finally Fixed

Check to see if both fans are working. The evaporator fan is in the freezer section and the condenser fan is by the compressor. Make sure the condenser coils are clean and air flow across them is not restricted. See if the compressor is running. Look for frost on the evaporator cover (freezer section back wall) indicating a possible defrost issue. Use your hand to feel for any frost or ice on the evaporator cover. I have a feeling once your cooling issue is solved so will your dispenser problem be fixed.
After the ice dispenser quit dispensing and the compressor wouldn't come on when the temp. started to increase inside and I had resorted to unplugging the fridge every 6 hrs, for 15 min, to get the compressor to come back on...I finally had the service guy come out. He replaced the High Voltage board (mother board?) and all is well.
He didn't explain what was going on with the bad board. I know you need a higher voltage to start the compressor. I guess you need pretty high voltage to start the auger in the ice maker, too. What really happened?
By the way, he first brought out a reconditioned board to replace the original. The board was either too old or too new cause it was not programmed with my 2006 model code. So, had to put a "new" board in. Then it worked!
Thanks for the suggestions. I did try what you recommended, first.

As a side note, I read "Consumer Reports" a couple of years ago and bought a 30" gas stovetop based on their highest recommendation. It's a KitchenAid. Now, two years later, I read "Consumer Reports" and they say don't buy the 30" KitchenAid gas stovetop because you can't get the flame low enough to simmer anything. I could have told them that two years ago. And, they're just getting around to testing that little feature?

Thanks again for the help (a month and a half ago). It took me awhile to admit I wasn't going to figure out what was wrong by myself.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,119
Location
McMullen Valley, Arizona
Sounds good, glad your refrigerator is back to normal again.:)

Yes, I don't rely heavily on what Consumer Reports says.:)

Jake
 
Top