• Please note, some of the links on our site are affiliate links (Learn More)

IKEA / Whirlpool Oven IBS350PXS01 Dead No Display

Xray

Premium Member
Joined
Feb 12, 2022
Messages
5
Location
Denver
Model Number
IBS350PXS01
Brand
Whirlpool
Age
1-5 years
Greetings all, I hope I can find help here as I've tried many repairs/replacements but with no results. I have an IKEA (Whirlpool) Oven IBS350PXS01. We did the self clean cycle, came back to it and it was dead. Electric is still getting to it, but no display or anything.

Initially I assumed it was one of the two thermal fuses (#32 in the Diagram). The other fuse is located on top of the unit (but I've never found in any diagram; THERMODISC G4A01084C FUSE, THERMAL, 84 C, 10A, 250V). Changing both of these showed that there is continuity, but the oven still didn't turn on.

I've since replaced the transformer, the control board, the user control and display board, but it's still not turning on. My thought of what to replace next is the door lock motor (it remains in locked position currently). But at this point, it seems something else could be the problem that I'm not understanding. Basically, power is getting to it, the display won't light up, and the door doesn't unlock. The oven doesn't do any oven-y things.

Does anyone have any insight into what I should try next? Pretty weird...

Thanks all!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
I'm attaching your tech. data sheet below.

Something is very odd then, you will need to trace the power to the transformer, BLACK and WHITE wires to the transformer should read 120 volts AC, then BLUE and BLUE out of the transformer should be 20.3 volts AC.

schematic.jpg


Jake
 

Attachments

  • techsheet-w10201489-reva.pdf
    1.5 MB · Views: 39

Xray

Premium Member
Joined
Feb 12, 2022
Messages
5
Location
Denver
Thank you for your reply Jake, I've definitely done this (although fairly adhoc as I've been testing everything I can "easily" test), but I'm going to do it again tonight with a fresh brain. It's super bizarre and I was hoping to avoid the elec schematics if full, but here we are! I'll let you know what I find. Thanks again!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Ok sounds good, yes keep us posted.

Jake
 

Xray

Premium Member
Joined
Feb 12, 2022
Messages
5
Location
Denver
Ok! I gave it a proper go finally; everything tested well. I followed along with your schematic and notes here (and the one that came with the unit —fortunately both are the same).

Nothing shows any sign of an issue that I can see —readings were what they were supposed to be, continuity seem to be doing what it should be doing (thermal fuses are happy). A real head scratcher.

Maybe it’s the lock motor? But it tests within range, so ¯\_(ツ)_/¯

Any new thoughts?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
That's very odd, I'm puzzled too.

Its best to contact Whirlpool at 1-866-698-2538 to come out and see what's going on.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
You bet! Let us know what they find if you could please, I'm very curious too!

Jake
 

Xray

Premium Member
Joined
Feb 12, 2022
Messages
5
Location
Denver
Believe it or not I’m still working on this! so at this point, I have replace all the thermal fuses, the transformer, and the control board. I’m pretty sure the transformer was the culprit. But regardless all of this all has been fully replaced. And when I turn the power on, the oven comes back on —but only for about a minute, and then it gives me fault code F 04.

I called whirlpool IKEA on this, and they weren’t entirely sure what the fault code meant, but suggested I change the control board. At this point I don’t see how it’s the ward council changed it three times just to be safe. I’m absolutely stumped. Anybody have any idea what fault code 04 is? Or how to remedy?

when I supply power to the oven, I can change the clock I can choose bake, light, etc. —seems like everything Is ok. Although the oven doesn’t start to heat, which I think it is because it might be too short of a window before the fault code displays and stops all action.

for what it’s worth I replaced the transformer twice now, and the control board three times. All with the same results. Any suggestions would be highly welcome and super appreciated, thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Anybody have any idea what fault code 04 is? Or how to remedy?
That is very strange, your tech. data sheet skips right over it from F03 to F05 no mention of F04 at all, I'm puzzled too.

If you contact Whirlpool at 1-866-698-2538 and have a tech come out, the tech can call the factory on a special HOTLINE tech number from your house, and the factory can get involved in investigating what the problem could be.

Jake
 
Top