• Please note, some of the links on our site are affiliate links (Learn More)

KDFE104DSS2 Kitchenaid Dishwasher not advancing washing. Soap lying in bottom of tub/good heat

Jtaylor20

Premium Member
Joined
Jan 3, 2020
Messages
8
Location
Alabama
Model Number
KDFE104DSS2
Brand
KitchenAid
Age
6-10 years
KDFE104DSS2 Kitchenaid Dishwasher not advancing washing. Soap lying in bottom of tub/good heat.

Replaced pump/motor assembly 2 years ago.
1st time I ran Diagnostic- codes 6-4 and 8-2/

Second time I ran it, only showed 6-4. Any advise is appreciated. Thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
6-4=float switch stuck or inlet valve problem

If your water inlet valve and fill cycle are working good, then remember what I mentioned in my last thread?

It's most likely a bad wash motor, this has become a common problem as of late, many members here have reported the same. In fact I had 2 this past Sept. 2018 in Parker, Arizona that did the exact same thing, and the new wash motor fixed them both.:)

Look at post #7 here: FIXED 665.13472N411 What to check on why it only washes about 5% of the cycle.

I'd first check to see if your getting 120 volts to the wash motor when it should be in the wash cycle. His Kenmore 665 made by Whirlpool, and Whirlpool owns KitchenAid, and uses the exact same wash motor yours does.

Take the wire connector off the wash motor and use a multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor below.

Here is the wash motor assembly you can order:
W11032770 Motor-Pump


Here's the video to replace it:

Or for a LOT LESS MONEY you can get the complete motor/sump assembly:
WPW10605057 PUMP&MOTOR


Let us know what you find.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top