• Please note, some of the links on our site are affiliate links (Learn More)

KDRS483VSS03 KitchenAid Dual Fuel Range Oven Not Heating Properly

dman535

Premium Member
Joined
Apr 7, 2006
Messages
17
Location
Nashville, TN
Model Number
KDRS483VSS03
Brand
KitchenAid
Age
1-5 years
When trying to bake with this oven the control panel will report a temperature, but the oven does not maintain it and the panel does not update the loss in temperature. Here is the scenario played out.
1. Heat oven to 450 convect bake.
2. After unit reaches temp - turn oven off
3. Set temp to same heat point within seconds of turning off and the temperature will show 50+ degrees less.
4. Sometimes oven temp will freeze at preheating stage while the oven temperature does not decrease, turning oven off and then on again shows updated temperature lower.

I replaced the temperature sensor as the original was out of spec when checked with an ohm meter. I have not pulled out the replacement to see if it is still within spec. I am concerenced that its the main board as its not reporting back the correct temperature as the oven is supposedly trying to heat.

All other functions see normal with no error codes.

Added complete model number
 
Last edited by a moderator:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Your missing some digits after the last "S". We need those last two digits please.

It should be one of these below:
KDRS483VSS00
KDRS483VSS02
KDRS483VSS03
KDRS483VSS04

I did locate a service bulletin, what is the serial number of this range?

Code Dates: D400 through D540
Possible Concern(s):
Oven Lights may not shut off when door is closed, temperature complaints or oven shuts down.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Thanks! I'm attaching that service bulletin below, even though your serial number is out of range at D633

That service bulletin is for Code Dates: D400 through D540

But you can read it and try what it suggests first.

Jake
 

Attachments

  • servicepointer-w10780875-revd.pdf
    1.2 MB · Views: 24

dman535

Premium Member
Joined
Apr 7, 2006
Messages
17
Location
Nashville, TN
Thanks for posting. I wil dig into a bit. I cycled the door two dozen times this morning and the switch seemed to be operating properly. Does this unit have any type of built in diagnostics?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Yes, I'm attaching your tech. data sheet below.

On Page 2 Do--->To Enter Diagnostics Mode

Let us know what fault code, if any, you get.

Jake
 

Attachments

  • W10403297-reva.pdf
    1.7 MB · Views: 18

dman535

Premium Member
Joined
Apr 7, 2006
Messages
17
Location
Nashville, TN
That is great info, thanks for sharing.

The only error code was for the temp sensor when I swapped it out.

I contacted Kitchen_aid today and it looks like I still have about 6 months of warranty on the control board and the heating elements. They are sending out a tech to look at it, and hopefully resolve it. Will report back what I find.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Ok great!

Yes, let us know what they find.

Jake
 
Top