• Please note, some of the links on our site are affiliate links (Learn More)

KDTE204ESS0 not cleaning and no error codes


Premium Member
Mar 8, 2023
New Hampshire
Model Number
6-10 years

Looking for some help as to what might be wrong and what to try next. My KitchenAid KDTE204ESS0 is not cleaning and I am finding undisolved detergent packs in the bottom. I have run the service diagnostic cycle multiple times and get no customer or service error codes.

After finding the first load of unclean dishes I checked and cleaned the filters then ran a cycle with a cleaning tablet. Of note, with the cleaning tablet cycle I choice high temp wash and sani rinse but at the end of the cycle the sanitized button was flashing which I since read in my manual means the load did not reach temperature to sanitize. After the cleaning tablet cycle I attempted another load of dishes but again it did not clean and the detergent pack was undisolved. I have run numerous diagnostic cycles which result in no codes. Most recently, I ran another normal cycle (but without dishes) with a cleaning tablet and also added a regular detergent pack as I would if there were dishes and this time both the detergent pack and part of the cleaning tablet were undisolved on the bottom. After I ran a diagnostic cycle which again resulted in no codes. For this last diagnostic cycle I left the undisolved pack and tablet on the bottom and they did not disolve (or even seem to move) during the diagnostic cycle.

Not sure if it is relevant or not but 8 months ago or so it was acting similar and I got the 7-1 code but after cleaning the filter (which was clogged) running the diagnostic cycle and clearing the history it was worked without an issue until now.

Any input would be greatly appreciated. Thank you!

Added complete model number
Last edited by a moderator:
Hi, Your missing the last digit in your model number, we would need that first. Read it from the model number tag, which is located inside the door on the tub frame.

Here's the results I get:

Yes, when this problem happens its usually a bad wash motor, seen this many times on my service calls. The only way to really check is while its running a wash cycle after it fills with water. This bad wash motor problem can cause the error code 7-1 because no water is passing over the heating element, thus you get that 7-1 error code.

To verify that--->Look at post #7 here: FIXED 665.13472N411 What to check on why it only washes about 5% of the cycle.

You can check to see if your getting 120 volts to the wash motor when it should be in the wash cycle. His Kenmore 665 is made by Whirlpool which owns KitchenAid and uses the exact same wash motor yours does.

Take the wire connector off the wash motor and use your multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor.
(click to enlarge)

Here's the wash(circulation) motor for your model:
Pump and Motor Assembly W11032770

Here's the video to replace it:

Let us know what you find.
Ok, thank you! I will test it out.

Just curious though, does it make sense that it could have been an issue 8 months (when it showed the 7-1 code), resolved, and now be not working again but with no error codes?
7-1 does not need to show up when the wash motor is bad. When the wash motor runs after it fills you should hear water splashing in the tub. Undissolved detergent packs in the bottom means no water was splashing in the tub.
If you feel that you have benefited from this site, and would like to show your appreciation.