• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KDTE234GPS0 Kitchenaid Dishwasher - Error Code 4-3

Status
Not open for further replies.

rfgomide

Premium Member
Joined
Nov 10, 2020
Messages
4
Location
Canada
Model Number
KDTE234GPS0
Brand
KitchenAid
Age
1-5 years
My Kitchenaid Dishwasher model KDTE234GPS0, is 16 months old, and it is not actually washing the dishes anymore. The cycle starts, hot water fills in, stays there for 2-3 minutes or so, doing nothing. Then, the water drains out, and after a minute, hot water fills in again. This pattern is very consistent, and as I mentioned, the actual washing process never starts.

I ran the diagnostic, and it takes approximately 20 minutes to complete. As a result, I hear a beep at the end followed by error code 4-3 (4 led flashes - 2-sec pause - 3 led flashes). After 5 secs, the same code repeats twice and then goes off.

Reading the Service Error Codes means a faulty wash motor that may need to be replaced, but I'm not sure which part is this. Maybe it is the "Circulation Pump"? I'm not sure.

Have anyone experienced the same issue and can share a bit with me?

Much appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,736
Location
McMullen Valley, Arizona
Yes, you will need a new wash motor(aka circulation motor), but getting the whole pump/motor is less expensive than the wash motor itself.

Here it is for your model:
Pump and Motor Assembly W11085683


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,736
Location
McMullen Valley, Arizona
Look at post #7 here: FIXED 665.13472N411 What to check on why it only washes about 5% of the cycle.

If you want to verify it, I'd first check to see if your getting 120 volts to the wash motor when it should be in the wash cycle and running after it fills with water.

Take the wire connector off the wash motor and use a multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor assembly.

Jake
 

rfgomide

Premium Member
Joined
Nov 10, 2020
Messages
4
Location
Canada
Hi Jake!

Thanks for your response and for sending the URL. I will buy the whole thing as recommended.

I've just tested the current flow and the motor is receiving 120 volts consistently.

I can't believe this 16-month old dishwasher broke the most critical part of it so soon.

I'm happy to find the issue and disappointed at the same time with Kitchenaid.

Thank you, Jake.

Ricardo
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,736
Location
McMullen Valley, Arizona
Glad you were able to verify it Ricardo!

Yes, I had two bad wash motors in Sept. 2018 in Parker, AZ. and the new wash motor/pump assemblies fixed them both.:)

Let us know how it goes when you get the new one installed.

Jake
 

rfgomide

Premium Member
Joined
Nov 10, 2020
Messages
4
Location
Canada
Hi Jake,

I have ordered the part but it seems to be Manufacturer back-ordered, so it may take a while until I get the part.

I will update once I install & test it.

Thanks again!
Ricardo
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,736
Location
McMullen Valley, Arizona
Yes Ricardo , its currently on back-order.

Yes, keep us posted.

Jake
 

rfgomide

Premium Member
Joined
Nov 10, 2020
Messages
4
Location
Canada
Surprisingly, the part has arrived today, then I installed it and boom! Dishwasher is fully operational now and it is working like a charm.

Thanks for your precious help, Jake, Much appreciated.

Ricardo
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,736
Location
McMullen Valley, Arizona
Excellent Ricardo, glad to hear the new Pump and Motor Assembly fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top