• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore 106.51335710 New Twist Ice maker cycling from home position to harvest position every 45 seconds_not making ice

twubker

Premium Member
Joined
Jul 25, 2022
Messages
2
Location
Weston, WI
Model Number
106.51335710
Brand
Sears Kenmore
Age
1-5 years
The ice maker was making a loud clicking sound. I found that the gearbox case was cracked. I ordered a new ice maker assembly and installed it however it does not work. The ice maker tray constantly moves from the home position, stops 45 seconds then moves to the harvest position, stops 45 seconds then back to the home position.

I ran the service diagnostics at step 29 initially the "IM Harvest Cycle Is On" led is lit, but after 10-15 seconds, then the "Switch Fault or Motor" leds are lit. The motor is good as it cycles back and forth. I tested the internal feedback switch with an ohmmeter and it cycles open, closes at what seems the appropriate times during the moving of the tray.

I measured the voltage between the tan wires going to the switch and only get around 4.6 volts not the 12.7 volts that the service diagram shows in the table (P70-3 to P70-4). Do you think that the problem is with the main circuit board or the user interface board, or the new ice maker?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
I measured the voltage between the tan wires going to the switch and only get around 4.6 volts not the 12.7 volts that the service diagram shows in the table (P70-3 to P70-4). Do you think that the problem is with the main circuit board or the user interface board, or the new ice maker?
Here's your ice maker tech data sheet that has troubleshooting in it: https://drive.google.com/open?id=1cM55ONghMG_V99Hdd-ysfueTDjV9Uvsq

Here's the ice maker for your model:
W10873791 Ice Maker


--->I'd first check for any frayed or broken wires underneath the freezer door--->Lots of members have found frayed and broken wires causing the ice maker/and or auger motor to be low voltage or dead completely. Remove your bottom kickplate grille, Remove the black wire harness loom too, broken wires can be underneath it.

Another member was having a similar problem here: FIXED: GSF26C4EXY02 Whirlpool Gold Ice Maker Problem Look at his post #6 he found frayed and broken wires underneath the freezer door, remove your kickplate and check for that first.

Here's another one with the same thing about the frayed and broken wires: FIXED: 106.51173310 Kenmore elite ice maker not working - no led light

Here's another: FIXED: Whirlpool WSF26C2EXF01 Door Icemaker Not Working

Let us know what you find.

Jake
 

twubker

Premium Member
Joined
Jul 25, 2022
Messages
2
Location
Weston, WI
I forgot to mention that I had already checked the wires underneath the freezer door. I didn't see any frayed wires. I also ohm checked from the connector at the ice maker to the connected under the freezer compartment it is showed the wires being good.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Ok,

Here's your ice maker tech data sheet that has troubleshooting in it: https://drive.google.com/open?id=1cM55ONghMG_V99Hdd-ysfueTDjV9Uvsq

It seems like you got a faulty ice maker, since your original one was not was doing that like the new one is.

Contact the place where you got the ice maker from and ask them to send you another one.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top