FIXED Kenmore 110.25132410 washer making horrible sound

Masonaj47

Premium Member
Joined
Apr 28, 2019
Messages
6
Location
SC
Model Number
110.25132410
Brand
Sears Kenmore
Age
1-5 years
I took the wash plate and hub off, not sure what I’m looking at here. I have pictures.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,096
Location
McMullen Valley, Arizona
Hi,

Its possibly the hub underneath the washplate, that's stripped.

Here's the hub for your model, its located underneath the washplate:
W10528947 Hub


I'd first check your hub to see if the teeth are starting to grind down.

The hub has screws that hold it in place, you will see them once you remove the washplate.

Look at these photos below of the teeth grinded down to smooth, then compare them to yours.

Let us know what you find.

Jake
 

Attachments

Masonaj47

Premium Member
Joined
Apr 28, 2019
Messages
6
Location
SC
A Better picture of hub...

C1BEC617-D647-44F6-8F66-91AF3232A473.jpg
After looking at your picture, it most definitely looks like the hub. Is it normal for it to only wear the teeth on the bottom?
Should I buy the washplate as well?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,096
Location
McMullen Valley, Arizona
Yes, you will need to order the hub.

Yes, also order the washplate.

Here's the washplate for your model:
W10752285 Washplate


Jake
 

Masonaj47

Premium Member
Joined
Apr 28, 2019
Messages
6
Location
SC
Bought the hub and washplate, still made the noise. Saw where you had replied to another person about a nut that will loosen. Sure as the sun is shining here in the hot south, there was a nut laying underneath. Fixed that sucker!!! Ha!!
(Not upset about the washplate & hub cost, it would have been more to have a repair guy come out to the country and work on it. Besides, I needed them anyway.)
THANJ YOU!!!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,096
Location
McMullen Valley, Arizona
Top