• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore 665.14573N610 not filling with water consistently

bmwbikerusa@net

Premium Member
Joined
Nov 14, 2022
Messages
4
Location
Richmond VA
Model Number
665.14573N610
Brand
Sears Kenmore
Age
6-10 years
My dishwasher does not consistently fill with water. I can run the same cycle two times in a row, and the one time it will run perfectly, and the next time it doesn't sufficiently fill with water, as evidenced by the fact that the dishwasher detergent is still sitting in the bottom of the tub only partially dissolved. This happens with every cycle. It will run through the cycle, so if it hasn't gotten enough water, the food is baked on the items by the drying cycle. So, most things have to be handwashed. As stated, it doesn't happen every time. I replaced the control board, and I've checked for error codes, but there are no error codes coming up. Any suggestions as to what I should be checking/replacing to get it to work correctly every time?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,946
Location
Vicksburg Junction, Arizona
Hi, When it doesn't fill with water I always get my multimeter and set it on AC Volts and put my meter probes in the electrical connector at the water inlet valve and see if the meter reads 120 volts when it should be filling, if so and no water is going in, then your water inlet valve is the culprit.

Here's the water inlet valve for your model: W11175771

Also, have you removed and cleaned your filter screens?

Here's the filters for this model and the video is in the part link to show you how to remove/check-clean/replace the filter.

Pump Filter W10872845


Screen Filter WPW10463906


Jake
 

bmwbikerusa@net

Premium Member
Joined
Nov 14, 2022
Messages
4
Location
Richmond VA
Thanks for the information. I clean the screens regularly, so I know that isn't the issue. I will check the voltage on the inlet valve and see what it reads.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,946
Location
Vicksburg Junction, Arizona

bmwbikerusa@net

Premium Member
Joined
Nov 14, 2022
Messages
4
Location
Richmond VA
So, I checked the voltage to the inlet valve. It was showing 124 volts. So, I replaced the inlet valve, as well as the float switch. I've tried 2 different cycles, and the dishwasher is still not filling and running properly. I assume this is the time to call it quits and get a replacement dishwasher... Thanksgiving is definitely not a good time to have no dishwasher, especially if one has a house full of guests!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,946
Location
Vicksburg Junction, Arizona
How high is the water level coming up too after it fills?

When the wash motor begins to run, do you hear water splashing in the tub?
 

bmwbikerusa@net

Premium Member
Joined
Nov 14, 2022
Messages
4
Location
Richmond VA
Jake, after installing the replacement inlet valve and reinstalling the float switch, the dishwasher ran 2 cycles just fine. I've tried 2 more times, and all it does is click through the various steps, heat up, open the soap dispenser, but it doesn't fill with water. As such, I wasn't able to measure the water level since it hasn't filled since I saw your message. As much as I appreciate all of the assistance, I think I'm running out of options. So, it is time to buy my wife an early Christmas present...
 

406John

Premium Member
Joined
Oct 29, 2022
Messages
11
Location
Montana
Are you sure it's not putting water in and just not engaging the wash motor? I do warranty repair for Sears see this a lot with these whirlpool made kenmores leaving the soap pods undissolved, the unit will fill with water and run through the cycle but not engage the wash motor and, numerous times, will intermittently have the wash motor function but I ultimately end up replacing the wash motor.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,946
Location
Vicksburg Junction, Arizona
Are you sure it's not putting water in and just not engaging the wash motor?
That's exactly what I was just thinking.:)

The wash motors on these have been a problem child for some time now.

Here's the wash motor for your model:
Pump and Motor Assembly W11032770


Here's the video:

Its actually less expensive to order the entire sump/motor assembly, which includes the new wash motor already installed for you:
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top