• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore 665 Dishwasher Cycle Completion

apotter

Member
Joined
Apr 30, 2005
Messages
1
Location
, ,
imported post

I have a Kenmore Elite 665.15953000 dishwasher.

One month ago, I had the circuit board and touchpad replaced. Everything was working properly.

Last week I ran the dishwasher and believed it ran fine. When I opened the dishwasher, the soap dispenser had opened, but the soap was clumped up on the dishes and in the bottom pan.

I attempted to restart the dishwasher by selection Normal Wash, but when I pushed Start, 2 red lines appeared and the green 'Clean' light continues to flash and the washer never started.

I put the dishwasher through the test mode and I did not see any problems. After the test mode, I am able to start the dishwasher and it appears to run normally. The water heats up, the timer starts at 59 and begins to count down.

Unfortunately, when it gets to around 49 or 48 minutes remaning, it jumps to 2 minutes remaining on the display and finishes from there. At that point, I can't start it again unless I run in through the test mode first.

Any thoughts? I checked the connnections on the control panel and everything appears to be in order.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,222
Location
McMullen Valley, Arizona
imported post

Hi,

I have seen this problem you describe happen before.

There are 2 things to check:

1st, the Thermister





2nd: The heating circuit, make sure the heating element is getting hot, check it in the dry cycle for heat.

Hope that helps some.:cool:

Jake
 
Top