• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore 90 When I press the start button all I get is a buzzing sound

Hep038

Premium Member
Joined
Mar 9, 2005
Messages
2
Location
, ,
Model Number
110.66902690
Brand
Sears Kenmore
Age
6-10 years
Hey guys, I got a kenmore 90 electric dryer that just quit on me. When I press the start button all I get is a buzzing sound and nothing. Also I started to take it apart to see it the belt was stuck but I cannot get the back of the dryer off even after I take all the screws off. Is there something I am missing? All help is great appreciated.
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
24,058
Location
Ontario, Canada
Hi,

**When I press the start button all I get is a buzzing sound and nothing.**

Some possible trouble makers:

- seized motor

- broken belt

- siezed drum support ( roller wheel, etc ) holding the motor back from running

- bad motor

- something caught in the fan blower

- sour motor

**I started to take it apart to see it the belt was stuck but I cannot get the back of the dryer off even after I take all the screws off. Is there something I am missing?**

-Might- be like one of these?...

http://www.applianceaid.com/wpdryer_how-to.html

http://www.applianceaid.com/whirlpool-dryers.html#four

jeff.
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
24,058
Location
Ontario, Canada

Hep038

Premium Member
Joined
Mar 9, 2005
Messages
2
Location
, ,
Thanks for the help. I took everything apart and it looks like it is the motor.
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
24,058
Location
Ontario, Canada

SoGoFan

Member
Joined
Apr 1, 2005
Messages
1
Location
, ,
I have the same identical problem as Hep038, but my model # is: 110.69902890

Do you have any advice for me? Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,393
Location
McMullen Valley, Arizona
Hi,

Just the advice that Jeff1 posted, click the links he posted above, That may help alot.

Jake
 

itzallmyne

Member
Joined
May 29, 2005
Messages
1
Location
, ,
I have a kenmore 90 series electric dryer that takes an hour and a half to dry. I have cleaned out all traps and hoses and still no dry. do you have any sugestions
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
24,058
Location
Ontario, Canada
Hi,

**kenmore 90 series**

Model#? Above isn't it.

Where is my Model Number? | Appliance Aid Some model# helps.

**dryer that takes an hour and a half to dry**

A copy:

Q-Dryer takes too long to dry or multiple times to dry a load


A1-Pull the dryer out away from the wall. Unhook the vent from the dryer completely. Do not put anything over the dryer exhaust on the back of the dryer. Do a normal load with the vent unhooked. If it dries better or ok like this then the problem is in the dryer venting. Like a blocked vent pipe or a smashed or restricted vent hose.

A2 - If the vent doesn't make a difference, then check the blower wheel for excessive lint build up, check that there isn't anything stuck to the air intake baffle inside the drum, (i.e. the screen on the back wall of the dryer when looking into the drum). Check the lint filter chute for blockage. Check that the heating element isn't shorted to ground ( Grounded Elements On Electric Dryers | Appliance Aid ). Check the exhaust temperature of the dryer. A meat or pocket thermometer can be used for this. It should cycle approx between 120 degrees and 160 degrees. Check that the drum seals are not worn out.

jeff.
 

Dad of 5

Member
Joined
Jun 11, 2005
Messages
1
Location
, ,
Kenmore Model# 110.60922990 dryer cuts out after 15 min, buzzes on re-start. Ohmed out 4-prong t-stat on blower housing, showed continuity, opened up at 180 degrees in electric skillet. T-stat on heater housing showed continuity andin an electric skillet opened up at 200 degrees. BUT, thermal cut off on heater housing showed continuity, but in an electric skillet, would not open up even at 340 degrees. I hope this is it and not the motor. What d'ya say?

PS Sorry if this is a double post.
 
Top