• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore Elite dishwasher # 665.12793K311 not drying properly

fred93

Premium Member
Joined
Dec 2, 2018
Messages
10
Location
NC
Model Number
665.12793K311
Brand
Sears Kenmore
Age
6-10 years
I have a Kenmore Elite dishwasher Model # 665.12793K311 Serial # F42514518 that I purchased in 2015. I recently replaced the sump housing & diverter motor assembly in order to fix a water leak. The leak has been fixed:

After I did this repair, I noticed that the dishwasher did not dry the dishes as well as it did before. I searched for this problem and found this: https://www.applianceblog.com/mainf...-12773k311-not-washing-and-drying-well.59955/ I did the checks that were suggested :

Do this first before running the diagnostics:
■Make sure the rinse aid is full. The machine can't dry the dishes without it.
■Start the machine on a normal wash cycle, tub empty and no soap. Listen for the fill cycle to end then open the door and check the water level.
■Close the door and let it wash for about one minute. Open the door and check for suds on the water. If there's suds cut back on the amount of soap you use. Close the door and let it finish the wash cycle.
■Listen for the drain pump/motor to turn on. Before the fill starts open the door and see if all the water is drained out. Make sure the drain hose loops higher than the bottom of the sink before the connection to the drain or disposer.

I also checked to see if the fan was working & it was. The heater element was also working. The vent that is at the top left corner of the door seemed okay but I did not know how to remove the grate cover to actually looking inside of the vent area.

I checked the flow of the drain hose water by looking in the garbage disposal-it seemed okay as far as I can tell.

All of the suggestions above checked out okay. I have not checked the dishwasher for codes.

One thing that I looked at after a complete wash cycle with "Smart dry" option, was the sump. I removed the filter basket and I noticed that there was water in that area. I have no idea how much water should be in that area!?

After I replaced the sump housing & the diverter motor assembly I did one change to the drain hose. Please note that the drain hose comes from the factory with a loop in the hose that is attached to the outside of the dishwasher tub. My dishwasher is not right next to the sink cabinet--it has one small cabinet between the sink and the dishwasher. The one change that I did was to loop the drain hose inside the sink cabinet because it was in the way of the storage area under the sink (see pix).

The only other thing that I did, that was different from the videos that I saw online, was that I turned the dishwasher over so that the top was on the floor and I was working on the bottom (which at that point was on the top) to replace the sump housing & diverter motor assembly--I don't know if the caused any problems?
 

Attachments

  • drain hose.jpg
    drain hose.jpg
    316.9 KB · Views: 27
  • side vent.jpg
    side vent.jpg
    337 KB · Views: 27
  • water level.jpg
    water level.jpg
    341 KB · Views: 28

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,790
Location
McMullen Valley, Arizona
Your drain hose is fine, yes a little water in the sump there is normal.

You just twist the vent with a flat-head screwdriver and a hammer counter-clockwise to remove it per the video below.


Everything you mentioned above sounds like its doing fine. Its very important to run the hot water at the sink first before you start the dishwasher, so the first patch of water that fills is not cold.

I'm attaching your tech. data sheet below, check the error codes.

Jake
 

Attachments

  • Tech Sheet - W10543820 - Rev B.pdf
    1,019.9 KB · Views: 26
Top