kenmore model 790.7885

retlaw

Premium Member
Joined
May 3, 2009
Messages
4
Location
new jersey
Range does not heat when BAKE is pressed, but does heat if PRE (preheat) is pressed. Broiler is fine.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,991
Location
McMullen Valley, Arizona
Hi,

There should be 4 more numbers after the "5" at the end of your model#. The model# tag is located on the side front frame after you pull out the storage drawer.

Sounds like the control board is bad, and will need to be replaced, I can link you to the one for your model once you post the rest of your model#.

Jake
 

retlaw

Premium Member
Joined
May 3, 2009
Messages
4
Location
new jersey
Jake,

The remainder of the model number is 2602 (790.78852602) which is supposedly just the color code for subject model. The control board is likely to cost approximately $170.00. Is there some troubleshooting that one can perform to reset/repair the control board before replacing it?

Thanks,

Retlaw
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,991
Location
McMullen Valley, Arizona
Thanks Retlaw,

Unfortunately, Kenmore doesn't supply online tech. sheets for me to link you too, You will likely have a tech. sheet in the console you can diagnose it with.

But I'm interested in know what happens after you press bake? Does it let you put the temperature in that you want to bake at? If it lets you, then you press start nothing happens? If you look in your oven do you see the oven igniter glow bar putting out an orange glow in the bottom of your oven?

If you have a voltmeter you can test the voltage from the bake output terminals on the control board, it should read 120 volts.

Jake
 

retlaw

Premium Member
Joined
May 3, 2009
Messages
4
Location
new jersey
Jake,

When BAKE is pressed on the touch panel, one is able to enter the desired temperature, but the igniter does not glow. No oven.

If PRE is pressed (instead of BAKE), and then the desired temperature entered, the broiler igniter glows (and the top broken bar on the display illuminates). After a while, the broiler igniter will turn off and the display will show that the oven is operating (solid bottom bar on display illuminates; top bar extinguishes). The display will continue to display PRE. After several more minutes (while the display continues to show PRE), the oven igniter glows, and the oven finally engages. The display continues to show PRE until the preset temperature is attained at which time the oven beeps and the desired temperature is displayed.

I guess I could live with this, but it's not the way things should work.

Retlaw
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,991
Location
McMullen Valley, Arizona
Ok Retlaw,

Then it does sound like your control board is the culprit, but yes its expensive, so if you can still use it on PRE and you don't want to put out $170 for a new one, I'd say just leave it for now.

Here's the control board for your model, its a little bit higher here, but all parts ordered from our site comes with a 30 day FULL refund policy, even if you installed it and it didn't fix the problem:
Manufacturer part number 316418703 is RepairClinic item number 1062445
316418703



Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,991
Location
McMullen Valley, Arizona
Glad to help Retlaw.

Jake
 
Top