Kenmore model 790.92903013 smooth top hot surface lights not coming on

rab474

Premium Member
Joined
Aug 19, 2019
Messages
3
Location
Murphy,NC
Model Number
790.92903013
Brand
Sears Kenmore
Age
1-5 years
Hello
Today the hot surface indicator lights on 3 of the burners stopping working. Elements heat fine, element light works properly. Looking for direction as to possible causes, diagnosing.Guessing it’s one of the burner switches is bad
Thanks
Roger

Added complete model number
 
Last edited by a moderator:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,301
Location
Murray, Utah 84107, United States
Hi Roger, I need the rest of your model number. Read it from the tag on the machine. Click here: Appliance Parts follow the link “How to find a model number”
 

rab474

Premium Member
Joined
Aug 19, 2019
Messages
3
Location
Murphy,NC
Hello....the full model number is: 790.92903013, brand is Kenmore.

Should also add that the warmer drawer and warmer burner hot surface lights work as they should.
Thanks
Roger
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,322
Location
McMullen Valley, Arizona
I located it Rick, I'm attaching it below.

Jake
 

Attachments

rab474

Premium Member
Joined
Aug 19, 2019
Messages
3
Location
Murphy,NC
I may be missing something, the PDF file showed the oven not the cooktop.
Are the hot surface lights wired in series, so if one switch or sensor is bad, all the indicator lights will be off?
Thx
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,301
Location
Murray, Utah 84107, United States
No it appears 1B to 2B is the hot surface sensor and each element has one.
 
Top