• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Kenmore Pro 790.42003600. Upper oven does not hold temperature all the time. Some times it does some times it doesn't.

Status
Not open for further replies.

Peter Dahlquist

Premium Member
Joined
Jul 4, 2021
Messages
3
Location
20186
Model Number
790.42003600
Brand
Sears Kenmore
Age
6-10 years
Kenmore Pro 790.42003600 Upper oven will not hold temperature. Example start at 350 deg and it will drop to 300 deg or less. I have changed the mode control switch, the temperature sensor and the temperature control switch.
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,759
Location
McMullen Valley, Arizona
Hi Peter, Another member had this same problem, and it was the relay board that fixed it:

Your model uses the same exact relay board as his:
frigidaire-board-316443910-ap3960187_01_m.jpg


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,759
Location
McMullen Valley, Arizona
Ok Peter, sounds good, keep us posted.

Jake
 

Peter Dahlquist

Premium Member
Joined
Jul 4, 2021
Messages
3
Location
20186
OK I swapped out the relay board ($234 I think). The old board had a resistor that bit the dust and left a scorch mark. Calibrated the oven. Seems to work.
Temp does drop but pops back up quickly. I realize how the oven works, heating element is on until temp is reached then turns off. Cycle continues till cooking complete. It will start at 350 degrees drop to about 300 deg pops back to 350 deg. Have a new heat sensor, new temp control switch and mode select switch also.
So I'm assuming it works.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,759
Location
McMullen Valley, Arizona
Excellent Peter, glad to hear the new relay board fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top