• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore Range 721.96043610 Upper oven element not turning red.

Rcarlson52

Premium Member
Joined
Dec 21, 2021
Messages
4
Location
Sandwich, MA
Model Number
721.96043610
Brand
Sears Kenmore
Age
1-5 years
Double Kenmore elite oven less than 5 years old. In the upper oven the baking element is not turning red, broiler works. Replaced oven control board and element. Checked continuity of element and it reads 3 ohms.

Checked voltage across element and it reads 240 volts. It does cycle with the relay. Oven heats but seems to only be using the broiler. At a lost as to what to check next as what little I know about ovens, if the element is getting 240 volts, it should be working.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
129,011
Location
Redmond, Oregon

Rcarlson52

Premium Member
Joined
Dec 21, 2021
Messages
4
Location
Sandwich, MA
At one point it was and stopped a couple of months ago. Just got around to troubleshooting it. Since the range is only three years old I assumed the oven control board was bad as the element looked alright. Didn't have a meter to check. Replaced the board, still bad, replaced the element still bad, got a meter finally to check voltage and continuity. The oven isn't cooking right, it's only cooking with the broiler element.
 

Rcarlson52

Premium Member
Joined
Dec 21, 2021
Messages
4
Location
Sandwich, MA
So I decided to disconnect the broil, oven preheated to 350 in about 15 minutes using only the baking element so that seems to be working. I'm 99.9 % sure that until a couple of months ago it used to turn red. So at this point the oven broiler, at least to me, is coming on too much during baking. The bottom of what I'm cooking doesn't seem to cook the same as it was a few months ago. Is that possible or am I imagining things?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
129,011
Location
Redmond, Oregon
Your not imagining things, it should turn red.

But I want to be 100% sure your meter reads 240 volts AC at the BAKE ELEMENT terminals when you put each meter probe on each BAKE ELEMENT terminal at the same time.

Jake
 

Rcarlson52

Premium Member
Joined
Dec 21, 2021
Messages
4
Location
Sandwich, MA
When I disconnected the broiler, I did recheck the voltage and it was 240 VAC, however I just checked it again while preheating and I notice I have 240 on the baking element but the broiler is off. I hear the relay, voltage on baking element goes to zero and the broiler now comes on. Is that normal?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
129,011
Location
Redmond, Oregon
That I don't know, this Kenmore 721 is made by LG, and it can't locate the schematic for this model to say if the bake and broil element alternates ON and OFF.

Hopefully another tech that works on these Day in and Day out can shed some light on it for you.

Other than that you can contact Sears to come out at 1-800-469-4663 to see what's going on.

Jake
 
Top