• Please note, some of the links on our site are affiliate links (Learn More)

Kenmore refrigerator model 596.72383410 starts making very loud noise and things won't freeze well in the freezer

peakpeaktan

Premium Member
Joined
Apr 14, 2021
Messages
2
Location
Boston
Model Number
596.72383410
Brand
Sears Kenmore
Age
1-5 years
I have a three year old Kenmore refrigerator which has the model of 596.72383410. I noticed that it has started making very loud noise (please refer to the video) and things won't freeze well in the freezer. In the video you can also see that the panel in the back has a lot of ice build up on it...

P.S. Three months ago there was once it stopped cooling completely and we had the repair guy come in and replace the defrost heater. Now I guess something is broken again.

It's like a nightmare that we have to deal with this refrigerator.:( Any help will be appreciated! Thanks in advance.


 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States
The evaporator fan blade are hitting something, most likely a wire in the harness or frost. Take the freezer baskets out and remove the evaporator cover (freezer compartment back wall) You'll be able to see it from there.
 

peakpeaktan

Premium Member
Joined
Apr 14, 2021
Messages
2
Location
Boston
The evaporator fan blade are hitting something, most likely a wire in the harness or frost. Take the freezer baskets out and remove the evaporator cover (freezer compartment back wall) You'll be able to see it from there.
I managed to remove the back panel and saw huge amount of ice buildup as expect. I used hair dryer to melt all the ice.

I uploaded two images:

before:
IMG_0064.jpg


after:
IMG_2671.jpg


My question is:
How do I diagnose further? Thanks.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States
One of the defrost components failed. There's only three components that make up the defrost system, the heater, defrost thermostat and control board. Check the heater and thermostat for continuity. Check the defrost thermostat after the machine has been running for a while. The thermostat needs to be below 40°F to show continuity. If the heater and thermostat check good, replace the control board.
Snapshot_16.jpg



whirlpool-evap-mtr-harness-wpw10514110-ap6022520_01_l.jpg

whirlpool-heater-evap-33bm-wp12729128-ap6005557_01_l.jpg
 
Top