Kenmore/Whirlpool ice maker issue

Keith5244

Premium Member
Joined
May 1, 2019
Messages
4
Location
Texas
Hello,

I just replaced my ice maker
ICEMAKER Whirlpool W10873791 a month ago. Nothing I am doing is fixing it.

I have tried unplugging it for awhile after the swap. I have tried letting it all unthaw etc.

Unfortunately, I don’t know what model Refrigerator I have. I believe it’s a Kenmore Cold spot I bought it second hand and a little older. The stickers are all removed from it for the most part.

It is the same setup as this video.

[video=youtube_share;OCqxZcpce-E]https://youtu.be/OCqxZcpce-E[/video]

Any help would be appreciated
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,906
Location
McMullen Valley, Arizona
Hi,

Lots of members have found frayed and broken wires causing the ice maker/and or auger motor to be dead. Remove your bottom kickplate grille, Remove the black wire harness loom too, broken wires can be underneath it.

Another member was having a similar problem here: FIXED: GSF26C4EXY02 Whirlpool Gold Ice Maker Problem Look at his post #6 he found frayed and broken wires underneath the freezer door, remove your kickplate and check for that first.

Here's another one with the same thing about the frayed and broken wires: FIXED: 106.51173310 Kenmore elite ice maker not working - no led light

Here's another: FIXED: Whirlpool WSF26C2EXF01 Door Icemaker Not Working

Let us know what you find.

Jake
 

Keith5244

Premium Member
Joined
May 1, 2019
Messages
4
Location
Texas
Never would of thought to look there. Had 4 wires broken. Beige, Black, Red, Green with a stripe. Of course it was broken tight by the door exit for the harness. I stripped and twisted both side, soldered them each in the mild. Wrapped each separately with electrical tape and then electrical taped the bundle together.

That made progress because through the diagnostic test I can get it to harvest but won’t fill with water and shows “short” on the tray temp


Water fill for a glass works fine
 

Keith5244

Premium Member
Joined
May 1, 2019
Messages
4
Location
Texas
Switch the plugs on the water fill valves in the back used a glass to activate the fill in the front and it filled the ice maker tray but not the glass.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,906
Location
McMullen Valley, Arizona
I'm not understanding, you fixed the broken wires, If you don't have the model number of your refrigerator, I at least NEED the part number of your tech. data sheet so I can follow that diagnostic test you did.

Jake
 

Keith5244

Premium Member
Joined
May 1, 2019
Messages
4
Location
Texas
It’s working now. About 2 hours later it started filling with water and almost 24 hours later I have a half of a bucket of ice. I am going to try and go back into diagnostics to try and see if I can speed up this time

Per your question. Tech sheet is W1067077A I believe
 
Top