• Please note, some of the links on our site are affiliate links (Learn More)

KESA907PSS00 Kitchenaid range/oven asking for temp probe setting....

CFDBattChief

Premium Member
Joined
Oct 22, 2009
Messages
27
Location
Iron Station, NC
Model Number
KESA907PSS00
Brand
KitchenAid
Age
More than 10 years
Came home to find the oven asking for a temp probe temperature setting. We haven't used the probe at all, and not sure why we would suddenly find this message. No matter what you enter for a temp, it doesn't clear the message.
Upon unplugging the unit and plugging it back in, you get the display showing "Kitchen-aid" with a red "06" underneath it. Then along the bottom you get, "AM71 U171 EEKE0-232". (picture attached) After you set the clock, it immediately goes to a screen asking for you to set the oven probe temp. Attempting to enter some temperature does not let you get past this screen.

Any help would be deeply appreciated.

CFDBattChief
 

Attachments

  • Kitchenaid KESA907 Display.jpg
    Kitchenaid KESA907 Display.jpg
    496.5 KB · Views: 45

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,312
Location
Redmond, Oregon

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,790
Location
Murray, Utah 84107, United States
Check for any error codes, Press Cancel to put the machine in an idle mode. Then press CANCEL-CANCEL-START
 

CFDBattChief

Premium Member
Joined
Oct 22, 2009
Messages
27
Location
Iron Station, NC
Jake, that sounds like a great idea. I did make an attempt to search for someone with the same issue, but came up empty.
After taking the front panel off just to be sure I didn’t have moisture from a pot boil over causing the problem, I put it all back together and got the same message…and yes, what you had in quotes is exactly what it said. However, this time I was able to push the cancel button about a dozen times and the display finally went to the normal state of just displaying the time.
I will get the part and replace the jack. Thank you so much for the very quick response and your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,312
Location
Redmond, Oregon
Ok, sounds good, let us know how it goes.:)

Jake
 
Top