• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KFIS29PBMS02 KitchenAid Refrigerator Program code for new control board

Mike 7175

Premium Member
Joined
Sep 22, 2021
Messages
5
Location
Canada
Model Number
KFIS29PBMS02
Brand
KitchenAid
Age
6-10 years
I Recently purchased a new UI panel and control board for my KFIS29PBMS02 due to the icemaker and water dispenser not running at all. I installed both. When I powered up, the UI lit up and chimed. But no fans or compressors would start. Needless to say the ice maker and water dispenser didnt work either. I ran the diagnostics and many came back blank. A quick internet search led me to believe i needed to program the new board.

I can't for the life of me find instructions on how to enter a programming code. The service tag inside the unit has no numbers beside the word "Code" as well. I reinstalled the old UI and board and ran service test 26 and got back 00 00 00 for the code. I assume this is the correct code. Does anyone have any ideas of what I am missing? EDIT: the old UI and Board have the unit running but still no ice and water.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,872
Location
McMullen Valley, Arizona

Mike 7175

Premium Member
Joined
Sep 22, 2021
Messages
5
Location
Canada
Welp! I've been through two sets of control boards and interface panels and the fridge still wont run with the new ones. The panel seems to work fine but the fans and compressor wont run.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,872
Location
McMullen Valley, Arizona
What is the part number of the main control board you are ordering? and where are you ordering it from?

Jake
 

Mike 7175

Premium Member
Joined
Sep 22, 2021
Messages
5
Location
Canada
it comes as a set with the UI from repairclinic.com Part # on the box is W10759802 on the board is w10751275 the ui is w10751227
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,872
Location
McMullen Valley, Arizona
Ok, that's right. Still no programming is needed.

Here's the User Interface(Dispenser Board) and Control Board kit for your model:
Control Board W10759802


I did a look back and located another couple threads with a similar issue:

And it turned out to be the DELI board was the culprit.

--->What we do first to confirm if that's the problem is to disconnect that deli display U/I control board and then see if everything starts working fine again.

Pages 59 and 60 in this service book: https://www.dropbox.com/s/oq1qp0yieqypp0u/R-114 JOB AID W10444924.pdf?dl=0 Tells you how to access it to disconnect it.

Here's the DELI board for your model:
Dispenser-Control-Board-W10807593-05368430.jpg


Its in-stock here: W10807593

Let us know if that fixes all the other issues once you disconnect it. Unplug your refrigerator first before disconnecting it.

Jake
 

Mike 7175

Premium Member
Joined
Sep 22, 2021
Messages
5
Location
Canada
Like a charm! Still waiting to see if the maker is making ice but the motor and auger work fine. Water is running as well. I am extremely disappointed with the appliance repair shop that was recommended in my area. When he showed up he checked the water valve, and then got on the phone with Kitchenaid. They were not helpful i guess. After searching the groups and youtube I found the tech sheet under the hinge later and realized that all the call center was doing was walking him through the test. He recommended a main control board change and quoted me almost $1000. I passed and paid the $150 call out fee. His information is what led me to the control board, which was ultimatley false. Thanks so much for the help and I hope this post can help others with the same issue!
 

Mike 7175

Premium Member
Joined
Sep 22, 2021
Messages
5
Location
Canada
Like a charm! Still waiting to see if the maker is making ice but the motor and auger work fine. Water is running as well. I am extremely disappointed with the appliance repair shop that was recommended in my area. When he showed up he checked the water valve, and then got on the phone with Kitchenaid. They were not helpful i guess. After searching the groups and youtube I found the tech sheet under the hinge later and realized that all the call center was doing was walking him through the test. He recommended a main control board change and quoted me almost $1000. I passed and paid the $150 call out fee. His information is what led me to the control board, which was ultimatley false. Thanks so much for the help and I hope this post can help others with the same issue!
Update Ice maker is working as well!
 
Top