FIXED KGYS700JQ0 KitchenAid Dryer won't start - none of the obvious reasons

tedrussel5

Member
Joined
Jun 11, 2019
Messages
3
Location
webster, ny
Model Number
KGYS700JQ0
Brand
KitchenAid
Age
6-10 years
Kitchenaid Dryer, KGYS700JQ0, will not start when you press the start button. I checked all the obvious thinks - Thermal fuse good, thermostat good, door switch, start button, belt all good. even the extra little thermal switch on the back is good. Occassionally the unit will "start up" when on the sense dry cycle, like it should after the clothes are dry - this tells me the motor is good. That leaves the timer - I opened it up, all the contacts look clean. Red to black wires are "made" when it is on time dry or sense dry. I am out of ideas - if the dry sensor is bad, it should still work on timed dry, no? It won't start on "air tumble only", which should rule out any problem with the heat system, right? When I've had dryers before and the glow plug went, the motor would still start. Can anyone think of anything I am missing? Thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,874
Location
McMullen Valley, Arizona
Hi Ted,

I am out of ideas - if the dry sensor is bad, it should still work on timed dry, no? It won't start on "air tumble only", which should rule out any problem with the heat system, right?
Yes, and Yes.

I located another member with the exact same problem you have, and uses that exact same timer and the new timer fixed it:

Here it is:
WP3976570 Timer


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,874
Location
McMullen Valley, Arizona
Ok, sounds good.

Jake
 

tedrussel5

Member
Joined
Jun 11, 2019
Messages
3
Location
webster, ny
Ok, sounds good.

Jake
It worked! Got the new timer, carefully transferred all the wires, and zoom - started up in timed, sensed, and air tumble. Must be the wheel tabs were worn down and the contacts not being made. Other than that, the old timer seemed ok. Thanks! I owe you Jake!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,874
Location
McMullen Valley, Arizona
Excellent Ted, glad to hear the new timer fixed it.:)

Thanks for the update!

Jake
 
Top