• Please note, some of the links on our site are affiliate links (Learn More)

KitchenAid Dishwasher KDFE104DSS0 Metal Dust and Error Codes

RussW

Premium Member
Joined
Aug 22, 2022
Messages
3
Location
California
Model Number
KDFE104DSS0
Brand
KitchenAid
Age
6-10 years
I'm getting a film of brown/gray 'dust' on the lower pan and walls towards the bottom of the wash tub. I've tried running Finish dishwasher cleaner, and it did not clear out. Ran several cycles with no dishes and noticed that most times the machine is not filling much above the intake area inside of the heating element when it's stopped/open. I added water during the cycle (about a gallon) and that filled it to raise the float switch. Running extra cycles helped remove some of the film from the walls but not entirely. The film has a metallic smell like steel or ferrite.

I ran the diagnostic cycle on it and it returned the following codes:

8-1 "Open Regen Valve Circuit or Solenoid"

8-2 "Open fuse on control to Regen valve"

In searching for parts I can't find it to determine what the Regen Valve is 🤷‍♂️
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,082
Location
Redmond, Oregon
Your model doesn't seem to have a REGEN VALVE.

Here's the parts diagram for your model:

--->FOR MODELS WITH WATER SOFTENER: REGEN VALVE

For that dust issue, look here:

Jake
 

RussW

Premium Member
Joined
Aug 22, 2022
Messages
3
Location
California
Interesting about the pans/sheets shedding metal or a 'coating' but we hardly ever wash metal or nonstick pans in our machine. The only thing I could say that we regularly wash that is metal would be our stainless silverware, and it does not appear to be rusting.

I understand that my model is probably not equipped with the 'Regen Valve', but why is it trowing a code if that component was not equipped on the machine?

Also noticing that the machine is not filling with water on the 'normal' wash cycle, only enough water to cover the pump intake area, not nearly up to the float valve. If that's happening regularly, I could see there being too much concentrate of detergent in the small volume of water.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,082
Location
Redmond, Oregon
I understand that my model is probably not equipped with the 'Regen Valve', but why is it trowing a code if that component was not equipped on the machine?
That's what I don't know either. Never seen that before myself on my service calls.

Also noticing that the machine is not filling with water on the 'normal' wash cycle, only enough water to cover the pump intake area, not nearly up to the float valve. If that's happening regularly, I could see there being too much concentrate of detergent in the small volume of water.
Yes, that's possible, usually on these machines they don't fill with much water anyways.

If the amount of water is extremely low, take video of it in the tub and take another video of the normal fill you see on other cycles.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top