• Please note, some of the links on our site are affiliate links (Learn More)

Kitchenaid Dishwasher KDTE404DSS does not fill with water

Phosguy

Premium Member
Joined
Nov 26, 2020
Messages
2
Location
Shakopee MN
Model Number
KDTE404DSS
Brand
KitchenAid
Age
6-10 years
Our Kitchenaid dishwasher KDTE404DSS just started acting up. When starting a new load and press start, the unit does NOT fill with water. I just learned from this forum (thank you) how to run a diagnostic check. Waiting for results. What am I to see? A red light instead of a blue light?
Any ideas? Thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
115,867
Location
McMullen Valley, Arizona
Your missing the last digit in your model number. The model number tag is located inside the door on the tub frame.

Here's the results I get:
KDTE404DSS0
KDTE404DSS1

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
115,867
Location
McMullen Valley, Arizona
Thanks!

When it DOESN'T fill with water, you will need to check for 120 volts at the electrical connector that attaches to the water inlet valve. If your meter DOESN'T read 120 volts when it should be filling, first remove your tub float to make sure there isn't a foreign object underneath it or gunk buildup underneath it.

Here's the float for your model:
Float WPW10195036


When you click the link to the float you will see a video of how to remove it.:)

Looks like they changed how to remove it, now you have to go from underneath and move the float stem out of the channel its in, then it will pull out.

It used to just pull out from the top without doing anything underneath it.:)

If you find nothing underneath it, next check your float switch.

Here's the float switch for your model, when you click the link to it you will see 2 videos, 1 on how to access it, 1 on how to ohm test it:

If your float and float switch are good, and you get 120 volts at the water inlet valve electrical connector, when you first start a new cycle, then that means the water inlet valve is the culprit.

Here's the water inlet valve for your model:
Water Inlet Valve W11175771


Jake
 
Top