• Please note, some of the links on our site are affiliate links (Learn More)

Kitchenaid French Door fridge KRFF707ESS01 evaporator coil freezing up

vplucero

Premium Member
Joined
Dec 3, 2020
Messages
9
Location
California
Hello. I am having the same issue. I have read the thread and related thread for possible fix:

I have follow up questions.
1. I believe I have to remove the lower drawer to get full access. Can anyone share how?
2. I see there are some test to troubleshoot. How to I get access to the test? Is it on the front panel?

TIA
532CF612-6993-4742-BAF7-541FCAB1E6B9.jpeg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon

vplucero

Premium Member
Joined
Dec 3, 2020
Messages
9
Location
California
Update: applied the recommendations below last 4/28. Will check status after 7-14 days.

1. Thermistor Location - adjusted to 0” - .25” to right of ridge.
2. Drain Pan Level - installed new.
3. Evaporator depth in Housing - fixed. Previously touching the housing.
4. Evaporator Cover a. Tabs b. Screws c. Gasket - checked. All good.
5. Defrost Settings - changed as recommended.
6. RKV functionality - don’t know how to check
7. Door leveling - checked, all good.
8. Door gasket sealing - checked, all good.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Sounds good, yes keep us posted.

Jake
 

vplucero

Premium Member
Joined
Dec 3, 2020
Messages
9
Location
California
Just an update. I checked about 7-10 days after the corrective actions and found ice underneath the pan. The fins are clear (No ice). So it may be coming from the back wall? Also, the ice maker starts to make ice intermittently. It gathered ice once this morning and looks like it hasn’t add any.

E5392149-8D6D-4ED6-9D92-5AC0F741E1C8.jpeg

B986608D-E9B3-4D21-83A9-3F169D79DAD1.jpeg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Did you remove the evaporator cover to see the evaporator coil completely Like I mentioned in post #2?

Jake
 

vplucero

Premium Member
Joined
Dec 3, 2020
Messages
9
Location
California
only when i applied the suggested fixes. I didn’t remove it to check for results. What do you suggest?

TIA Jake

Vincent
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Remove it again and take a photo of it and upload it here, so we can see it please.

Also make sure the evaporator fan motor that mounts above it is running as well.

Jake
 
Top