• Please note, some of the links on our site are affiliate links (Learn More)

KitchenAid KFIS20XVMS4 - Replaced control board, can't program

rinnigan

Premium Member
Joined
Nov 11, 2022
Messages
3
Location
Washington
Model Number
KFIS20XVMS4
Brand
KitchenAid
Age
More than 10 years
My KitchenAid KFIS20XVMS4 recently stopped cooling. Front panel buttons work, but when pressed, no activity except all button lights come on. Based on similar experiences shared online, I diagnosed and replaced the main control board (W10312695) with a third-party compatible board.

When I restore power:
  • yes interior fans turn on, does not turn off
  • no cooling/compressor
  • yes interior lights work normally
  • exterior screen turns on, does not turn off -- no PE0 000 code flashes
  • water dispenser light comes on, does not turn off
  • water dispenser and ice dispenser features appear operational
  • water + LL, release water, hold for 3 seconds does nothing -- screen remains illuminated and blank
I'm stuck. I've tried 2 replacement boards from 2 manufacturers (both listed as a product replacement match). Any ideas or suggestions? Everything I've found in the forum and online starts with PE0 000 flashing and I've not managed to get that to happen.

Thanks in advance!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,710
Location
Vicksburg Junction, Arizona
Its always best to get the OEM main control board.

Here's the OEM main control board for your model:
Electronic Control Board WPW10312695


Screenshot 2022-11-12 13.35.23.png
 

rinnigan

Premium Member
Joined
Nov 11, 2022
Messages
3
Location
Washington
Update: Tried for the 3x time with an OEM board. No change.

On install + power restoration, the unit powers on with a slight 'pop' from the door water unit (I got hopeful..) and then...
  • interior fans come on and stay on,
  • exterior lights come on and stay on
  • display panel turs on and stays on
  • ⚠️ no PE0 000 flashing ⚠️
  • interior lights work when door open
  • water + LL, release water has no effect
Anyone have a helpful 'something else' I could try? 😥

Thanks in advance!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,710
Location
Vicksburg Junction, Arizona
I diagnosed and replaced the main control board (W10312695) with a third-party compatible board.
That's the problem, get the OEM board I posted the link to above and you will be back in business.
 

rinnigan

Premium Member
Joined
Nov 11, 2022
Messages
3
Location
Washington
Oops, I think I wasn't clear... I tried what you recommended.
  • Attempt #1: non-OEM (Feikeer) board. FAIL.
  • Attempt #2: non-OEM (Primeco) board. FAIL.
  • Attempt #3: OEM (Whirlpool) board. FAIL.

The OEM board has exactly the same behavior after install. Lights are on, nobody home!

Does anyone have a 'next step' I could attempt to get things back to working order?

Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,710
Location
Vicksburg Junction, Arizona
Where did you get the OEM Board from? OEM Boards need to come from a appliance parts site that deals with OEM ONLY. Like AppliancePartsPros and RepairClinic

I've replaced hundreds of these boards in the last 35 years and all the OEM boards never had this issue you are having and they ALL programmed prefect.

It you still can't program it with the OEM Board--->You will need to contact KitchenAid to come out at 800-422-1230, then the KA tech can call the FACTORY HOTLINE from your house, if he/she doesn't know, to investigate this problem.
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top