• Please note, some of the links on our site are affiliate links (Learn More)

KitchenAid KFIS29BBMS02: Sabbath Mode misbehaves, shuts down compressor and fan

JBZG

Premium Member
Joined
May 24, 2020
Messages
3
Location
NYC
Model Number
KFIS29BBMS02
Brand
KitchenAid
Age
6-10 years
We chose this model because of the Sabbath Mode feature (which, in case you unintentionally get into that mode, is toggled On or OFF by pressing Light & Options together for 3 seconds).

We use it each week, since we bought the unit. Until recently, no problems.

The past few weekends, apparently setting Sabbath Mode ON resulted in 25 hours of defrost -- we got water on the floor from melting of the accumulated ice-cubes in the ice-maker bucket; and ice-cream in the freezer went soft. Once we toggle the mode OFF, it returns to normal operation, and a cup of water placed in the freezer compartment gets frozen overnight. So it's the logic board's operation when in Sabbath Mode that is faulty; the compressor and fan(s) are fine.

Any suggestions appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,522
Location
McMullen Valley, Arizona
Hi,

There is a service bulletin involved with this problem on your model. There have been some problems with the deli display U/I(user interface) control shorting out and causing this problem your having now.

Erratic dispenser and/or ice maker operation
Deli Control display changes
Door ajar light and/or beep won’t turn off
Erratic User Interface operation

--->What we do first to confirm if that's the problem is to disconnect that deli display U/I control board and then see if the Sabbath Mode feature starts working fine again.

Pages 59 and 60 in this service book: https://drive.google.com/file/d/1L0agZKw9MnwG_p_a9kCFnhvK0kqoncF5/view?usp=sharing Tells you how to access it to disconnect it.

Here it is for your model: WPW10732682

Let us know if that fixes it once you disconnect it. Unplug your refrigerator first before disconnecting it.

Jake
 

JBZG

Premium Member
Joined
May 24, 2020
Messages
3
Location
NYC
Jake --

Thanks for the advice. I unplugged the unit for a few minutes, and now it behaves properly. Apparently the instability manifests itself only after a long period continuously plugged in.
But it is still under a warranty (one more month), and I would like to file a claim. Can you provide a link to the service bulletin you cited? Is there an upgrade to one or the other logic board to correct the problem?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,522
Location
McMullen Valley, Arizona
Yes, I'm attaching it below.

The new deli display U/I control board does come already upgraded when you order it.

Jake
 

Attachments

  • Service Pointer - W10666199 (Erratic Dispenser).pdf
    1.7 MB · Views: 112
Top