• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KitchenAid KRFC704FSS00 - Ice maker slow, now non-operational

beatmstrj

Premium Member
Joined
Aug 2, 2022
Messages
3
Location
SoCal
Model Number
KRFC704FSS00
Brand
KitchenAid
Age
1-5 years
Yet another KitchenAid ice maker issue. I have had this fridge for about 2.5 years (used when purchased) and it has always made ice incredibly slowly. It took about 3 days to fill up the ice box the first time and continues to be hilariously slow, now to the point where I don't even think it's trying anymore. I read through a bunch of threads here trying to determine what the issue might be but am definitely not an expert when it comes to appliance repair.

Model# KRFC704FSS00
Diagnostic test results:
14 Door Ice Box Thermistor - 23
16 Door Ice Maker Tray Thermistor - 16
31 Ice Box Average Temperature - 22
59 Ice Box Fan Test - "on" (can hear fan turn on)
79 Ice Bin Switch State - "01" (bin present - tested with bin present)
96 Water Valve General Test - "FF" (dispenses water for a few seconds then displays FF)
97 Door Ice Maker Valve General Test - "FF" (dispenses water slowly for a few seconds then displays FF)
120 Door Ice Maker Self Diagnostics - "PA" (all tests succeeded and some ice that was in the tray for a few days popped out)
128 GF2 Main Control Board Flashmap Version Number - 6.0.0

My icemaker is part# W10888882 and was manufactured 7/4/17 (label does NOT read P1SM)

Based on the above, my suspicion is that the ice tray temp is too high and therefor it's not releasing the ice as I see the service manual says it takes 80 minutes and must be 15 degrees for release. Not sure what normal operating range for the ice tray temp should be.
Let me know what I should check for troubleshooting.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
128 GF2 Main Control Board Flashmap Version Number - 6.0.0
You should have 7.0.0 software on that board.

The Replacement control board with updated software W11332011 has been updated to W11333076

Here's the service bulletin on it:
 

Attachments

  • service-pointer-w11033419D-ice-buildup-on-evaporator.pdf
    1.7 MB · Views: 55

beatmstrj

Premium Member
Joined
Aug 2, 2022
Messages
3
Location
SoCal
Thanks Jake,
Looks like I had an earlier service bulletin that stated 6.0.0 was fine. Is there any documentation or release notes available for the 7.0.0 control board and what it fixes? Would hate to spend $300+ dollars hoping it might fix my ice maker.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Is there any documentation or release notes available for the 7.0.0 control board and what it fixes?
Just what it says in the service pointed I attached in post #2.

Jake
 

beatmstrj

Premium Member
Joined
Aug 2, 2022
Messages
3
Location
SoCal
Progress report.

Shortly after I reported my fridge ice maker issue I noticed my food was no longer getting very cold. The interior temp of the fridge was hovering in the 60s I think. I quickly went out and got myself a backup fridge so I could salvage my food before everything went bad. I looked into the issue more and realized it was probably related to the ice maker problem. When I took the fridge apart I fully expected to find the evaporator coil frosted over. This become pretty apparent once I got all the shelves out and could see the ice forming underneath. There was so much ice in fact that the RC evap cover was frozen in place and I couldn't really remove it. I spent a while trying to steam out the ice and prying off the cover but wound up cracking the Styrofoam in several places. I'm fairly certain this cover was the older one with the improper gasket so I probably would have had to replace it anyway, but for those of you with the same problem, these covers are super fragile and will crack very easily if you're not careful.

I got the cover off finally to reveal a solid chunk of ice on the coil. Spent about an hour steaming all the ice off, then put it all back together with a new cover. I was able to get the controller board with the 7.0.0 SW revision so I replaced that as well.

So far everything is working great. The fridge is cold, the ice maker is making lots of ice again and everyone is happy. I don't know the proper amount of time to wait before I can truly say it's fixed, but at least I know what to look for in the future.

20220818_185509.jpg

20220818_213718.jpg
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top