• Please note, some of the links on our site are affiliate links (Learn More)

Kitchenaid KSSC48QMS01: Audio alarm, no lights turn on

hawk1

Premium Member
Joined
May 27, 2020
Messages
5
Location
san jose, ca
Model Number
KSSC48QMS01
Brand
KitchenAid
Age
More than 10 years
Occasionally, the fridge (both sides) lights don't turn on when the door is open. I also hear 3 beeps every 2 mins. None of the led lights turn on (expect the Door open) when I open the door. The fridge seems to be running, however the temp is very slowly rising. My thermometer shows 3.6f in FC and 41f in RC. I had set the fridge to 0f and 35f. The unit on top of the fridge is very warm. This has been going on for a while. I would just power off and then power back on from the panel. It would work fine for few days/weeks and repeat this again. Any troubleshooting advice? The unit is 16 years old.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,522
Location
McMullen Valley, Arizona
Make sure the condenser coil on the top of the refrigerator is clean and clear. If its clogged with lint or pet hair it will make the compressor run too hot and shut down prematurely. Also make sure the condenser fan is running at all times when the compressor is running.

For the lights problem, that's caused by your control board being bad. They have a service kit that replaces that control board now.

Here's the service kit for your model. Comes with boards, brackets, wire harness and instructions: Control Board W10818296.

It's also here: Control Board W10818296

Jake
 

hawk1

Premium Member
Joined
May 27, 2020
Messages
5
Location
san jose, ca
Update: fan and control board replaced but the original pblm still remains. 3 days after they replaced, the fridge went into a mode where it thinks the door is open (even though its closed) and auto shuts off. The tech also checked both the door-open switches. They are fine. They dont know whats next. Any ideas ?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,522
Location
McMullen Valley, Arizona
Did they install the Service Kit I posted the link to above?

Because the original control boards are no longer available, so they must of got a refurbished control board if they didn't order the Service Kit. Lots of times refurbished boards will not make it work.

If they did order the new Service Kit and it didn't fix it, have the tech contact the KitchenAid tech assistance line. All authorized KitchenAid service techs have the factory tech-line phone number.

Jake
 
Top