• ** REMEMBER! **The microwave can still shock you even unplugged!!

    ALWAYS discharge the high-voltage capacitor first if you even think your hands will come close to any HIGH VOLTAGE components.

    Jeff mentions this: Anything in the high voltage ( magnetron, capacitor, diode, wires to and from ):
    ...Use a metal ( not the shiny chrome type ) screw driver with a insulated handle to short across ( touch both at the same time ) the terminals of the high voltage capacitor to discharge it.

    From Jeff's site: http://www.applianceaid.com/component-testing.php

    Jake
  • Please note, some of the links on our site are affiliate links (Learn More)

KitchenAid Microwave KHMS2050SSS2. I have the same problem (intermittent beeping and it sometimes takes commands)

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
Model Number
KHMS2050SSS2
Brand
KitchenAid
Age
6-10 years
I have the same problem as in this thread:

I've replaced several boards at this point. I replaced the keypad (WP8206635) and I replaced the Control Board (WP8206488). I still have the problem. I have figured out that if I plug in the microwave but never clear the welcome screen, it doesn't beep. So effectively I can use the fan and light but that's it. I've looked up the second user interface board (WPW10391271) in the door and is VERY expensive. I would like some reassurance that this will fix it before I spend another $200 on this microwave. Does anyone have any guidance? Thoughts on why it isn't possessed if I don't clear the welcome screen? Thank you in advance.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
38,698
Location
Murray, Utah 84107, United States
OK, I'll assume you tried everything in the other thread. Are you getting any error codes? Here's the tech sheet. See if it can help:
 

Attachments

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
I did (try everything). I didn't have an error code before. But now the (newly installed) keypad doesn't work every time, so I'll work on checked that code again. I have to unplug and plug it back in several times for it to work.

I was finally able to get it to work and no error messages.
 

Attachments

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
38,698
Location
Murray, Utah 84107, United States

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
Great. Ordered and it's a lot cheaper than the other possibility. Thank you very much. I hope this is the last $120 I'll throw at this machine. Any more of this and I'll give the microwave a stage name.
 

guitardad

Premium Member
Joined
Apr 27, 2020
Messages
6
Location
New York
I just ordered the same part for the same PIA KitchenAid Microwave. This comes after replacing the touchpad, which made no difference at all to the beeping, malfunctioning, shutting down, etc. So I've got the Control Board here. After once again painstakingly opening the back of the oven door to reach behind the touchpad area, I cannot see where the control board would fit. Where does the control board go?? PLEASE HELP! Thanks.
 

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
If I'm not mistaken, you don't have to split the door back apart to get to this. This panel is behind the right metal piece. Please tell me if I'm wrong (my part hasn't come in yet, so I haven't jumped into it), but if it's behind the right plate, it's SO much easier to get to.
 

vanstone

Premium Member
Joined
Aug 24, 2020
Messages
2
Location
Canada
Thanks very much!
Did you have any luck? I was having the beeping/ghost press issue. It went haywire one night beeping constantly so I unplugged it. When I plugged it back the next morning the touch panel stopped working all together. I was curious if replacing the control board worked for you?
 

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
Took a month - finally got the part in today. I already replaced the main board behind the right side panel (I believe #12 above and the attached picture). I cannot find where #8 is. What needs to be removed to see it? Here is the part that came in and the panel on the right removed.
 

Attachments

Last edited:

vanstone

Premium Member
Joined
Aug 24, 2020
Messages
2
Location
Canada
In the drawing above #8 looks to be the board behind the right panel. I would take a guess that what you have is #12 and it looks like it's installed from the back of the microwave.
 

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
That is correct. It is in fact in the back. It's been a long time since I installed this monster. Whew! Not easy. I'll let you guys know if this fixed it. It sometimes doesn't start beeping for a bit, so I'll let you guys know later if this fixed it or not later. Just glad I don't have to take it out again. I'd rather take the door apart again. But on the positive side: there is only one control board left to replace.
 

Attachments

Last edited:

bmorgan

Premium Member
Joined
Jul 23, 2020
Messages
8
Location
70820
Disappointing news: I replaced that board and it ALSO didn't fix the issue. It took about 24 hours to start the beeping/ghost commands, but it did anyway. So I've now replaced both #8 and #12 in the above diagram and the keypad. The only thing left to replace is the Range Oven Control Board WPW10391271. Does anyone have any input on this board? At this point I've dropped about $400 on a 10 year old microwave. Awesome!
 

guitardad

Premium Member
Joined
Apr 27, 2020
Messages
6
Location
New York
In a belated reply to Vanstone and maybe Bmorgan as well, I had zero success with my last replacement part (Electronic Control Board - AP6012103). In addition, I damaged an unrelated wire due to difficulties with the door hinge. That was it for me, not worth this much time. So I pulled the oven out and bought a GE OTR microwave instead. Definitely not the Cadillac of microwaves, but it works and doesn't choose to run on its own!
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
38,698
Location
Murray, Utah 84107, United States
t took about 24 hours to start the beeping/ghost commands,
Where did you get the board? We've been seeing a lot of problems with boards coming from Amazon and eBay.
 
Top