• Please note, some of the links on our site are affiliate links (Learn More)

KitchenAid Refrigerator KRMF706ESS01 3 different issues - Dispensing Ice, defrost drain/diagnostic question and water dispensing.

Bridgetalaniz

Premium Member
Joined
Sep 18, 2020
Messages
19
Location
Bowmanville
Model Number
KRMF706ESS01
Brand
KitchenAid
Age
1-5 years
Hello,

Diagnostic Question:
I am having a few issues with my KRMF706ESS01. Last year I have had the control board, and evaporator fan replaced, and now I am having an issue with giant ice blocks in my freezer due to a leak coming from the drawer shelf. After doing some research seems the issue may be the defrost drain, which I am in the process of trying to resolve. When following the document "Service Pointer - W11092686 - RevG - Frost Build up on Evaporator", it says to change the defrost setting, however I have option 1-6, then 8. I do not have the option 7 on my fridge? Is this normal?

Ice Dispenser.
So the motor is making a sound when trying to dispense ice, and it passed the dianostic. Ice is being made, and is in the icebox, however when I try to manually spin the auger connected to the icebox it does not move. Its like the bolt it connects to is stuck and will not move. Have you heard of this before? Is this a part I can replace?

Water Dispenser
The water is coming out from the spout in a horrible flow, not smooth at all and water droplets everywhere, is there a solution you know that will fix? I tried cleaning with vinegar, to no avail.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,640
Location
Murray, Utah 84107, United States
Is the defrost sensor in the correct spot as per W11092686?
however I have option 1-6, then 8. I do not have the option 7 on my fridge?
Sorry I'm not following you. Where are these options?

Ice dispenser:
With the left RC door closed and ice paddle pushed check for 130 VDC at the auger motor. If the voltage is correct and the motor is not working replace the auger motor:

Water dispenser:
Do you have high water pressure? Have you changed the water filter. Did this problem just start?
 

Bridgetalaniz

Premium Member
Joined
Sep 18, 2020
Messages
19
Location
Bowmanville
#1.When entering diagnostic mode by pressing s1 & s2 i do not have service test 7. I have 1-6 and then 8 on. The option to change from auto to 8 hours.
#2. Thank you, I will test the voltage.
#3. I bought the fridge second hand, and it was always like this, i read calcium build up, but I'm not that's it, because nothing is clearing it up. Could there be another reason the water isn't dispensing smooth.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,640
Location
Murray, Utah 84107, United States
I have 1-6
Are you using SW5 to advance to 07?

Press SW1 and SW2 simultaneously for 3 seconds. Release both buttons when you hear the CHIME indicator.

The display will show 01 to indicate the control is in step 1 of the diagnostics routine.

Press SW5 to move to the next step in the sequence.

Press SW4 to back up in the sequence to the previous step.
 

Bridgetalaniz

Premium Member
Joined
Sep 18, 2020
Messages
19
Location
Bowmanville
That’s exactly what I’m doing. I quickly go pass step 4 so I don’t get stuck waiting in that step. There is step 5 step 6 and step 8…. No step 7.

Also question…. Can the drain issue (clogged or drain tray not flat cause other issues like water line getting frozen or ice maker not dispensing ice, or the ice in big chunks in the bucket? My water was dispensing fine and then wasn’t dispensing for a week or so and now it is working fine …. It’s like so many issues that come and go and I’m not sure if a clogged defrost drain could be the root cause or just a red herring.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,640
Location
Murray, Utah 84107, United States
You might not be able to change the defrost on that model. I'll see what I can find. Is the UI and lights working ok?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,640
Location
Murray, Utah 84107, United States
When I look up that model number, KRMF706ESS01 this is the tech sheet that comes up:
 

Attachments

  • KRMF706ESS01-tech-sheet-W10844356-RevA.pdf
    516.1 KB · Views: 6

Bridgetalaniz

Premium Member
Joined
Sep 18, 2020
Messages
19
Location
Bowmanville
So that explains the missing service test #7. Still confused regarding the other symptoms, and water dispensing sloppy. Ill guess I'll keep investigating. Purchased the drain pan, so lets see the behavior after that is installed. Cant believe the Auger motor is $200+
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,640
Location
Murray, Utah 84107, United States
Water dispensers can do weird things if the water pressure is too low or too high. Turn the water off for the machine and disconnect the supply line from the water valve. Hold it over something to catch water and have someone turn the water on. The pressure shouldn't be so low it takes 20 minutes to fill a glass or so high it ricochets off the bottom of your container and hits you in the face. Somewhere in between.
 
Top