• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KitchenAid Stand Alone Ice Maker KUIC15NRTS1 reservoir has to be filled by hand

Status
Not open for further replies.

Mckrapfl

Premium Member
Joined
Oct 29, 2021
Messages
2
Location
Texas
Model Number
KUIC15NRTS1
Brand
KitchenAid
Age
More than 10 years
My ice maker functions 100% when first turned on. After that, I have to fill the reservoir by cups of water. It continues to make perfect ice if I continue to fill it (less than optimal!!). I thought the pump was broken at first, but it fills up initially when I turn the machine on. It just doesn’t keep filling. I don’t see any leaks from the reservoir and the cap is in place. Is there a water sensor in the reservoir? I’m at a loss and hope someone can help:)
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,425
Location
McMullen Valley, Arizona
Sounds like a bad water level sensor.

Here it is for your model:
Sensor WPW10548509


Also check for corroded wires at the sensor connector.

Jake
 

Mckrapfl

Premium Member
Joined
Oct 29, 2021
Messages
2
Location
Texas
Thanks:) it was the water inlet valve. It was super low output so didn’t fill the reservoir in the allotted 2 minutes. Replaced and good as new. Interestingly, the water level sensor showed as faulty, but it was fine.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,425
Location
McMullen Valley, Arizona
Excellent, glad to hear the new water inlet valve fixed it.(y)

Thanks for the update!

Here's the water inlet valve for your model, in case others need it too:
Valve WPW10217917


Jake
 
Status
Not open for further replies.
Top