• Please note, some of the links on our site are affiliate links (Learn More)

Kitchenaid Supra KSCS25FKSS02 not cooling

joeslick65

Premium Member
Joined
Sep 4, 2009
Messages
2
Location
Ohio
My KSCS25FKSS02 side by side refrig (5+ years old) stopped cooling this afternoon. All the fans/lights on both the freezer and refrig sides are working, but the compressor is not running/blowing cold air/turning on. I turned off the power switch for a few minutes and turned it back on to see if this would reset the it. Late last night the ice maker seemed to stop working. This morning I did some trouble shooting and found the freezer was VERY cold/compressor was running continuously which resulted in the fill line from freezing up. I tested the ice maker and it worked fine afterwards. Later in the afternoon the freezer and refrig compartments were no longer blowing cold air/getting warmer. I transfered all our food to another refrig in the house. I suspect that the compressor control unit/compressor is the problem. I know that this unit has an invertor box in place of a relay switch. I need help to figure if this is the problem.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Hi,

Here's another member that had a similar problem here:
http://www.applianceblog.com/mainforums/whirlpool/16088-whirlpool-compressor-not-running.html
Yours uses the exact same inverter box.

Check to see if your condenser fan motor that sits next to your compressor is turning while your compressor is running. If not, then you would need the control board and not the inverter box.

But yours uses a different control board, here is your control board:
<a href="http://click.linksynergy.com/fs-bin/click?id=YO6223WzStY&offerid=142421.783990550&type=10&subid=">Manufacturer's Number: 2252159
</a><img alt="icon" width="1" height="1" src="http://ad.linksynergy.com/fs-bin/show?id=YO6223WzStY&bids=142421.783990550&type=10&subid="><a href="http://click.linksynergy.com/fs-bin/click?id=YO6223WzStY&offerid=142421.783990550&type=10&subid=">
<img alt="icon" border="0" src="http://www.appliancepartspros.com/PartImage.aspx?imgid=Z3BqLjFfbXNfOTUxMjUyMi9MUFcvc290b2hwdHJhcC8%3d"></a><img alt="icon" width="1" height="1" src="http://ad.linksynergy.com/fs-bin/show?id=YO6223WzStY&bids=142421.783990550&type=10&subid=">2252159

Let me know what you find.

Jake
 

joeslick65

Premium Member
Joined
Sep 4, 2009
Messages
2
Location
Ohio
Cooling/working again?

Jake,

Thanks for the help. I will inspect underneath/behind to see if the condenser fan is running on the compressor like the previous problem someone had with their control board. Last night I turned the refrig back on and placed a digital thermometer inside. The refrig seemed to be running again/cooling. This morning the freezer @ 14 degrees F & refrig @ 41 degrees F compartments are cold again. I am not sure what is going on. I will continue to check this during the day. The ice maker ,like I said in my previous post, went thru a cycle late last night when the unit was starting to work (auto filled the tray,re- harvested ice etc), but now this morning I noticed the tray never filled with water after it dumped the ice cubes over night. I wonder if the fill tube is freezing?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Yes, check your fill tube for the ice maker to see if there is an ice clog in it.

You may need to remove the ice maker to get access to it from inside the freezer.

You can use a hair dryer to unclog it.

Jake
 
Top