• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KitchenAid wont stay cool

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO
Model Number
KSRS25QGWH01
Brand
KitchenAid
Age
6-10 years
I have a side/by/side model KSRS25QGWH01 - manfg 4/98.
I bought it used last summer and it will run for about 6-8 weeks fine then it will stay about 53 in the fridge and 35 in the freezer no matter what the controls are set to. (when it is working I have to set the controls to the middle or it will get too cold and the thing works like it should)

After I unplug it for a few days/week I can plug it back in and it works fine again for a few weeks, then the same thing happens again.

When it gets to 53 and starts to act up, the compressor seems to be running non-stop but it does not get cold enough inside, so it appears to be calling for cool but it does not deliver so the compressor will run and run...

How do I start to troubleshoot this fridge?

thanks Kevin
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,933
Location
McMullen Valley, Arizona

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO
help again please.

Hello,
Evaporator coil is nice and frosty - evenly.
My defrost heater works - heats up nicely after I jumped the hot side of evap fan. It appears the defrost thermostat is on top of the evap coil, on the line going back to the compressor or something.

It appears that I dont have a timer but instead a control board.
Where is that thing? Under the ice/water controls or but the fridge/freezer adjustments/thermostat?

If it is just a board, which cost a lot, how can I trouble shoot it to ensure it is the board?
What is this thing doing or doing wrong, again the fridge cools down nicely for 4-6 weeks then it just goes to about 55 in the fridge and stays there until it sits unplugged(and defrosted) for a day or 2, then it works fine.
If the evap has lots of frost on it, why wont the fridge get cold?

thanks Kevin
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,933
Location
McMullen Valley, Arizona
Check behind your bottom kickplate, it just snaps off. You should see instructions to force it into defrost.

Yours may be similar to this one in this thread: Kenmore Coldspot 106.74253400 freezer not so cold(force into defrost)

Its likely you will also need this defrost board:
Defrost Control Board 4388932 Order now for same day shipping. 365 day return policy. RepairClinic.com


Its located in your console as seen here as #6: 10-Control parts for Whirlpool KSRS25QGWH01 - AppliancePartsPros.com

Jake
 

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO
HELP!!

Hello,
I bought a relay/defrost board in late August, it was all good until this morning when the something went wrong.

The evap coil was not cool, it had no ice on it.
I heard a relay clicking on and off every 5 seconds or so....

Let it rest unplugged all day, got a new relay board (my replacement had a lifetime warranty) put it in and head the relay on on the compressor kick on then off after a few seconds...keeps doing this...will not cool.

Is the relay bad/is the compressor bad?
How can I start to check the relay and compressor?
What should voltages should I see/what should things ohm out to?

thanks for your help!!
Kevin
 

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO

Econo Appliance

Appliance Tech
Joined
Jan 30, 2007
Messages
151
Location
San Diego CA
If your refrigerator is newer than 5 years old, don't mess with it, Call Whirlpool factory service. It has a 5 year warranty.

If the relay has debris falling out, it is most likely NOT the compressor. If the compressor is bad, usually the overload protector will burn out. The best test is to buy a new relay (inexpensive) and put it in. If it is still not working, and the refrigerator is less than 5 years, keep the old relay and call factory service. Before you call factory service, put all the old parts back on the compressor.
 

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO
Hello,
Thanks for the help.
I will try and buy the parts soon today and put them in tonight and let you know.

The unit was mfgd in 4/98 so it is past the compressor warranty.
I am on my own with this crazy thing....

thanks Kevin
 

haeffnkr

Premium Member
Joined
Mar 23, 2006
Messages
19
Location
St. Peters MO
Hello All,

Once again you all saved the day, or the refrigerator....

I replaced the relay and all is working well again...for now.

thanks for your help!!
take care
Kevin
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,933
Location
McMullen Valley, Arizona
Good job fixing it Kevin, glad its back to normal again.:)

Jake
 
Top