• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KODE500ESS01 KitchenAid double oven display went blank then one of the ovens turned on on its own...or at least the convection fan turned on

Status
Not open for further replies.

LeeNorman

Premium Member
Joined
May 14, 2021
Messages
5
Location
Canada
Model Number
KODE500ESS01
Brand
KitchenAid
Age
6-10 years
The past few days I've had intermittent issues with the KODE500ESS01 double wall oven.

The other day my wife swears the oven turned off by itself. The next morning I noticed the oven light turn on then off instantly and repeated this every few minutes. I turned the light on then the control panel went blank and unresponsive. I turned off the breaker for a few minutes and turned it back on with the same result. An error message popped up that I wasn't able to record before the display went out again. I shut the breaker off again and left it for half an hour. Turned it back on and had a F1E1 error. I was able to clear that and had a F6E0 error pop up after turning both ovens as well as the oven light on and off a number of times. I turned the breaker off overnight. I turned it on this morning and all seemed well for a while....I was able to turn on and off both ovens and the light no issues. Then out of the blue, the light blinked on and off, the display went blank then one of the ovens turned on on its own...or at least the convection fan turned on. I didn't wait after that, I turned off the breaker.

Am I looking at the control panel needing replacement? The relay control board? Something else?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,246
Location
Redmond, Oregon
Hi,

It would be the appliance manager that is the problem.

Here's the Appliance Manager for your model:
W11179310


Jake
 

LeeNorman

Premium Member
Joined
May 14, 2021
Messages
5
Location
Canada
Thanks for pointing me in the right direction. Changed that part and all appears good now!

I appreciate your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,246
Location
Redmond, Oregon
Excellent Lee, glad to hear the new appliance manager fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top