• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KRFC704FPS00 KitchenAid Refrigerator not cooling properly

Status
Not open for further replies.

Kowens

Premium Member
Joined
Jun 17, 2020
Messages
16
Location
Lawrence Ks
Foam cover was stuck to the evaporator....
Guess I need the cover with gasket and might as well replace the thermistor while I’m there.

is the new cover made of styrofoam and have the gasket attached?
 

Attachments

  • 1E24BF30-25AD-43D6-AF39-4304858154CD.jpeg
    1E24BF30-25AD-43D6-AF39-4304858154CD.jpeg
    74.4 KB · Views: 137

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,565
Location
McMullen Valley, Arizona
Yes you get everything when you order the evaporator cover:
Whirlpool-Refrigerator-Evaporator-Cover.jpg


Also look on page 6 of that service bulletin I posted--->Check the Refrigerator section evaporator thermistor for proper contact with the tubing.

Jake
 

Kowens

Premium Member
Joined
Jun 17, 2020
Messages
16
Location
Lawrence Ks
Got it sir, I assume the thermistor is placed in the linear part of the tube and not on the curve.

sure hope this fixes it
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,565
Location
McMullen Valley, Arizona
Yes, that is correct, per the photo you see of it in that service bulletin.

Jake
 

Kowens

Premium Member
Joined
Jun 17, 2020
Messages
16
Location
Lawrence Ks
Hi Jake,
Got the evap cover in yesterday and installed. The unit had thermistor fan and pantry diverter as well as an upgraded gasket and pad that rests against the evap.

everything has checked out fine this morning!!!!!!

i suppose the main board replacement coupled with the evap/thermistor replacement did the trick.

of notwhen going through this I found
1. Condenser air inlet blocked with dust/dirt
2. Main board at rev 4.0.0. (Needed 6.0.0)
3. Evap froze solid
4. Evap thermistor located a bit up the tube ( lowered on reinstall)

Thanks again for all the support !!!!!

Best Regards
Ken
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,565
Location
McMullen Valley, Arizona
Excellent Ken, glad to hear your back in business.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top