• Please note, some of the links on our site are affiliate links (Learn More)

KRFF507HPS00 Kitchen Aid Refrigerator will not power up

SouthmoreTX

Premium Member
Joined
Nov 1, 2021
Messages
7
Location
Houston
Model Number
KRFF507HPS00
Brand
KitchenAid
Age
1-5 years
I have a KRFF507HPS00.

Initially ice maker quit working. After a day noticed Power Failure on user interface. Noted a Power Outage and reset. Compressor would start for few seconds, user interface would light up, clicking on relays and then everything would shut down. Same issue after unplugging. Interface will not light up and so no way to diagnose problem. Is this main relay board problem or user interface board issue. How can I tell the difference.

How do I diagnose problem. How many different boards exist? Main Relay Board? User Interface board? Is there another board that should be replaced?

Regards
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States

SouthmoreTX

Premium Member
Joined
Nov 1, 2021
Messages
7
Location
Houston
Just replaced main board last night. Refrigerator started back up but shut down overnight. Plug back in noted clicking sound. But will not start back up.

On main board checked
120 VAC across P1-1 to P1-2. noted 122 VAC
12.7 VDC across P4-1 - P4-4. noted 12.7 VDC

Noted LED flashing off and on.
What is next?
 
Last edited:

SouthmoreTX

Premium Member
Joined
Nov 1, 2021
Messages
7
Location
Houston
Rick ---Initially have power at the main board connectors both P1 and P4 ....then everything shuts down. Then I unplug the unit and then everything starts ups for less than minute and then shuts down. So if the main board has power is it the UI?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States
have power at the main board connectors both P1 and P4 ....then everything shuts down.
OK, when everything shuts down, do you still have 120 VAC across P1-1 and P1-2?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States
+
Ok, 120V is constant when everything shuts down. Now check if the 12.7 VDC (P4-1 to P4-4) is constant when everything shuts down. If it is then recheck on the UI J2-4 to J2-6
 

SouthmoreTX

Premium Member
Joined
Nov 1, 2021
Messages
7
Location
Houston
We have moved forward. Checked all power. Replaced main board and UI. Noticed LED lights in ceiling off. Disconnected power to lights and freezer light.

Not sure why we had some many problems finding the issue. But looks like a short on the ceiling LED harness impacting the UI board. Have you seen this before?

I appreciate your ongoing coaching. Thank you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,317
Location
McMullen Valley, Arizona
Did you remove the P10 connector that goes to the LED lights and everything is working fine now?

Where the LED lights in both the freezer and refrigerator sections working good before you replaced the main board?

Jake
 

SouthmoreTX

Premium Member
Joined
Nov 1, 2021
Messages
7
Location
Houston
I checked power as you suggested and even tried the P10 connector removal as a last resort. But still had the same problem. I didn't notice when the LED lights went out. After I replace the main board and the UI then I notice the LED lights were out. So disconnected the power at the ceiling wire harness. Everything seems to be working now. Except I need to test/replace the Ceiling LED Wire Harness. My frustration was one tech said he was 99% sure it was the main board. We would not provide part number and wanted $1150 to replace the board. So I never called him back. Have you seen this problem before with the LED lights. Again thanks for all your help.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,797
Location
Murray, Utah 84107, United States
Check your serial number.
 

Attachments

  • KRFF507HPS00-w11460554-revd-LEDmodule-freezer light not working.pdf
    1.3 MB · Views: 28
Top