• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KRMF606ESS01 KitchenAid Refrigerator - Pantry Drawer User Interface & Water do not work. Ice does work

Status
Not open for further replies.

kodiwan

Premium Member
Joined
Aug 25, 2022
Messages
5
Location
70503
Model Number
KRMF606ESS01
Brand
KitchenAid
Age
6-10 years
Just yesterday the water dispenser quit working on our KRMF606ESS01 KitchenAid Refrigerator. At first the LED lights and the dispenser didn't work and the Code UAC was being displayed. I performed some troubleshooting getting into the service codes and some features began working again. Later i realized the Pantry Drawer User interface was not working so I tried unplugging the harness from both the back of the door and the user interface.

At the moment the ice maker still works and dispenses, but the water will not dispense. The water will dispense in service mode 46. The Pantry Drawer User Interface is still not working. Trying to figure out if its the wiring harness or the Aurora Board. Any help greatly appreciated. Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Check for 14 volts DC at the wire harness electrical connector that connects to the Pantry UI Board.

Here the Pantry UI Board for your model:
User Control and Display Board WPW10769076


Its in-stock here: WPW10769076


Service Test - 46 Water dispensing Test--->Displays the status of the water dispense valve. Press the water pad to initiate a water dispense. (00 = Water Dispense Valve Off, 01 = Water Dispense Valve On).

On the main control board volt test at P3-4(violet wire) to P1-2(white/black wire) should be 120Volts AC Output to Water Valve when Water dispensing, when the water dispenser paddle is pressed and the door closed.

Here's the main control board for your model:


Jake

I'm attaching your tech. data sheet below.
 

Attachments

  • W10844356-RevA.pdf
    516.1 KB · Views: 52
Last edited:

kodiwan

Premium Member
Joined
Aug 25, 2022
Messages
5
Location
70503
Jake,

Thanks for the info. I tested for 14Vdc at the connectors shown in the picture. I did not get any voltage reading. Do you know which are ground and which are power? I tried the blue and brown on the one connector and then a combination on the other. No luck.

Regarding the service 46. This does activate the water dispenser and it works.

I have not yet tested the control panel in the rear.
 

Attachments

  • 67F52229-C3AB-4EAB-B59A-5C147D391EF4.jpeg
    67F52229-C3AB-4EAB-B59A-5C147D391EF4.jpeg
    346.6 KB · Views: 49

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
J1A-1 is the tan wire J1A-4 is the orange wire, between those two you should have 14 volts DC.

I'm attaching your tech. data sheet below.

Jake
 

Attachments

  • W10844356-RevA.pdf
    516.1 KB · Views: 64

kodiwan

Premium Member
Joined
Aug 25, 2022
Messages
5
Location
70503
Alrighty... I do NOT have 14Vdc between J1A-1 and J1A-4.
I traced those wires in the diagram and there is 12Vdc @ Main Board P2-1 and P2-7 and also at the Power Supply P6-1 & P6-2. So it seem power is not getting to the Pantry Board.

Also, for some miraculous reason the Water Dispenser has started working again since messing with the wires in the back panel..

Guess next step would be to pull the wire hardness of the pantry door and Ohm it out?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Guess next step would be to pull the wire hardness of the pantry door and Ohm it out?
Yes, exactly.

Here's the wire harness to it:
Pantry Drawer Wire Harness W11170612


Here's the video to access it:

Jake
 

kodiwan

Premium Member
Joined
Aug 25, 2022
Messages
5
Location
70503
Thanks! After reviewing the video, made the decision to just order the harness and swap it out. Will let you know the results.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Ok, sounds good, yes keep us posted.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Excellent good job, glad to hear that.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top