• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KSCS25FVMS02 Kitchenaid no lights 3 beeps

WaterBoy2020

Premium Member
Joined
Oct 15, 2019
Messages
5
Location
Florida
Model Number
KSCS25FVMS02
Brand
KitchenAid
Age
6-10 years
Hoping someone can help. Will do my best to keep it short.

Kitchenaid Side x Side KSCS25FVMS02

Display and temp controls in fridge not showing lights or temp.

3 beeps every so often

No lights in fridge or freezer

Recently replaced the ice bucket full sensor and ice maker. Red light on senor is solid when flap depressed and making ice as should.

All functions appear to work properly.

Vacuumed a got of buildup off the evap coils from the bottom front, did what I could from the back as well. Thought this had it fixed, but getting beeps and no lights once again a few hours later.

Display on front (water ice) works as usual. Dispenses ice/water, makes ice. Everything seems cold and frozen as it should.

These steps are in order as completed. I chose 6-10 years from drop down, but I'm really not sure. Looked new when we bought the house in 2011. Any advice would be greatly appreciated!!
 

Attachments

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,017
Location
Murray, Utah 84107, United States

WaterBoy2020

Premium Member
Joined
Oct 15, 2019
Messages
5
Location
Florida
Dang Rick, that was fast! I was expecting a board, figured they stopped making them. My wife and I were shocked how quickly you were able to reply, and with item in stock as well. I'll be checking the wires as suggested tomorrow and ordering the board in short order. Not having to mail in my old board and live out of the garage fridge, that makes for a Happy Wife-Happy Life! Thanks again!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,143
Location
McMullen Valley, Arizona
As my X used to say Not so fast!
0df9d6dd.x120.gif


WaterBoy mentioned his interior lights were not working either, Rick doesn't that sound more like the main control board?

Shouldn't he check the P2 connector on the main board first? That sends 12 VDC (P2-2 to P2-3) to the display board.:)

The original main control board is No Longer Available, its been replaced by this kit:
Main Control Board W10823803


Jake
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,017
Location
Murray, Utah 84107, United States
Yep you're right Jake. I missed that and last night wife wasn't happy! LOL
 

WaterBoy2020

Premium Member
Joined
Oct 15, 2019
Messages
5
Location
Florida
As my X used to say Not so fast! View attachment 45847

WaterBoy mentioned his interior lights were not working either, Rick doesn't that sound more like the main control board?

Shouldn't he check the P2 connector on the main board first? That sends 12 VDC (P2-2 to P2-3) to the display board.:)

The original main control board is No Longer Available, its been replaced by this kit: Main Control Board W10823803

Jake
LOL Board is on the way, fingers crossed that's it. It's crazy, the fridge and freeze both seem to work fine. I can't really find a common circumstance that happens to cause the lights to go off and start beeping. It might last for an hr or more and then it just comes back on (lights and display). Let the tail chasing begin. I'll be sure to pass along anything I can find. Search youtube for blairs loveless marriage. Best wheel of fortune contestant ever. He was on earlier this week.

Thanks for the info!
 

WaterBoy2020

Premium Member
Joined
Oct 15, 2019
Messages
5
Location
Florida
Yep you're right Jake. I missed that and last night wife wasn't happy! LOL
So Jake, are you too thinking I have ordered the wrong board at this point? Should I have ordered the main board instead? Please advise and if you have a part number that would be great. As I mentioned in my previous reply, the lights and display are intermittent. When the lights are out and the control displays for temp ate dark, that's also when I'm getting beeps.

Thanks guys!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,143
Location
McMullen Valley, Arizona
Yes, because the interior lights are not working either and they are controlled by the main control board. Now if the interior lights worked but not the temperature display lights then I'd agree with Rick about the display board being bad.

If you have a multimeter you can confirm that by putting your meter on DC Volts and put your meter probes on the P2 connector PIN 2 and PIN 3 on the main board. That sends 12 Volts DC (P2-2 to P2-3) to the display board.

The original main control board is No Longer Available, its been replaced by this kit:
Main Control Board W10823803


Jake
 

WaterBoy2020

Premium Member
Joined
Oct 15, 2019
Messages
5
Location
Florida
Just a follow up. I swapped both boards, it's been about a week and all is well. No way I could go this long without the lights turning off or getting the beeps. Finally, I can check thia one off the list. Thanks for the help guys!!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,143
Location
McMullen Valley, Arizona
Excellent WaterBoy, glad to hear you are back in business. (y)

Thanks for the update!

Jake
 
Top