• Please note, some of the links on our site are affiliate links (Learn More)

KSCS25FVMS03 - All Interior Lights Out & Icemaker Nonfunctional BUT Fridge/Freezer Working???

Rick_AZ

Premium Member
Joined
Apr 26, 2020
Messages
2
Location
85248
Model Number
KSCS25FVMS03
Brand
KitchenAid
Age
6-10 years
Hello,

Greetings and have searched high & low for a thread with similar problem - however, could not find one. This is a side-by-side countertop depth fridge, a little less than 10 years old. Here's the symptoms that appeared concurrently a few days ago:
  1. all interior lights nonfunctional - fridge compartment & freezer compartment
  2. the icemaker does not function
  3. the front display functions / displays OK ; all 4 buttons function correctly (the housing dispenser light works fine Off/Lo/Hi)
  4. the front ice pad & water tab make correct chirp when depressed - however no ice or water flow out when the pad is pressed
  5. inside the refrigerator compartment, at top is the controller unit - where buttons seem to function - however, the LED number displays are non-functioning (dark/off)
  6. can cycle the 'sabbath mode' via controller unit - functions as expected and 'sabbath mode' LED light turns on/off as expected
  7. from the front display - can cycle through the service diagnostics modes
I've tried cycling on/off several times - however, no change.

I have the service sheet / wiring diagram (a bit tough to follow the wiring diagram lines) - where I have been trying to find a single point where above items meet up. This seems very perplexing to me since some items work, some don't - given all these concurrent symptoms - figuring comes down to either (a) control board at bottom rear (replace w/ control board service kit W10823803) or (b) control board at top, refrigerator compartment (replace w/ 2307037).

Greatly appreciate any thoughts / inputs if others have experienced this too - timing for this is obviously not good w/ COVID-19 and thankful the fridge/freezer are at least nominally working. Thank you much!

Best Regards,
Rick
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
108,910
Location
McMullen Valley, Arizona

Rick_AZ

Premium Member
Joined
Apr 26, 2020
Messages
2
Location
85248
Thank you very much Jake! I was leaning in that direction due to all the lights being out (figuring they are on their own simple circuit going only through the bottom control board) but certainly don't want to throw unnecessary $$s guessing which board is the culprit. So I have a new project for my "to do" list - thank you again for your quick feedback and part link - greatly appreciated!!

Best Regards,
Rick
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
108,910
Location
McMullen Valley, Arizona
Glad to help Rick!

Let us know how it goes.

Jake
 
Top