• Please note, some of the links on our site are affiliate links (Learn More)

KSDB900ESS2 KitchenAid Dual Energy Range - Panel Not Working

mmitsch

Premium Member
Joined
Jul 6, 2014
Messages
10
Location
Indiana
Model Number
KSDB900ESS2
Brand
KitchenAid
Age
1-5 years
We have a KitchenAid KSDB900ESS2 Dual Power Range (gas cook top and electric oven). It has a digital panel control panel for the oven.

This morning it stopped working. There are not lights on at all on the panel and the light in the oven is off. The gas cook top burners work fine.

I looked at some videos and it seems it could be the display panel itself or a control board.

Do any of you know if there is a way to diagnose which of these 2 is bad?

Let me know and thanks!

Mike

P.S. - I think the parts are as follows. If you know if these are correct let me know.

Display
Manufacturer Part Number W10913685
Manufactured by Whirlpool

Main Board
Manufacturer Part Number W11099784
Manufactured by Whirlpool

Added complete model number
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,986
Location
McMullen Valley, Arizona
Hi Mike, Your missing the last digit of your model number.

Here's the results I get:
KSDB900ESS0
KSDB900ESS1
KSDB900ESS2
KSDB900ESS3
KSDB900ESS4

Click here: Appliance Parts

Then you will see a link that says: How to find a model number.

Jake
 

mmitsch

Premium Member
Joined
Jul 6, 2014
Messages
10
Location
Indiana
Hi Jake,

Sorry about that, and thanks for replying!

It's KSDB900ESS2

I attached a photo as well.

I think it might be the control board. I read on the web that another user had experienced the same symptoms due to a mouse. I opened up the top and there were mouse poops on the board (and I am assuming mouse urine too). Since none of the lights on the front panel work this seems like it might have been shorted.

What do you think?

Mike
 

Attachments

  • IMG_5891.jpg
    IMG_5891.jpg
    55.6 KB · Views: 25

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,986
Location
McMullen Valley, Arizona
Thanks Mike!

Here's the parts diagram for your model:

I read on the web that another user had experienced the same symptoms due to a mouse. I opened up the top and there were mouse poops on the board (and I am assuming mouse urine too). Since none of the lights on the front panel work this seems like it might have been shorted.
You are absolutely correct Mike, it would be the control board you'd need to replace.

Here's the control board for your model you can order:

Jake
 
Top