KSF26C6XYY04 Kitchenaid refrigerator - how do i check the fault codes

bwenzel

Premium Member
Joined
Jun 4, 2019
Messages
2
Location
roseville
Model Number
KSF26C6XYY04
Brand
KitchenAid
Age
1-5 years
the fans run, no cold air and freezer is warm. need to check the fault codes but not listed in the manuals, how do i check the codes and the meanings of the codes before i purchase a mother board. and then, how do i reprogram the new mother board?

thanks in advance,

Brian W
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,083
Location
Murray, Utah 84107, United States
KitchenAid Refrigerator KSF26C6XYY04 / Repair Parts

Your machine doesn't use error codes. Instead, you can activate loads in service test mode. You'll need to check the load to see if it's working. A new board doesn't need to be programed. From your description it sounds like the compressor may not be running. Check for any frost build up on the back wall of the freezer compartment first. If there is no frost build up use service test mode to check the compressor


Use this image of your dispenser board for the switch numbers:
KSF26C6 control.jpg

Machine must not be in lockout prior to entering the service mode.

To enter diagnostics mode, press SW1 and SW2 simultaneously for 3 seconds.

Release both buttons when you hear the CHIME indicator.

The display will show “01” to indicate the control is in test one of the diagnostics routine.

Each test must be manually advanced.

Use SW5 to advance to the next test or SW4 to go back to the previous test.

The test number is shown first followed by the status of that test two seconds later.

When the test number is being shown, the “Amber LED” will be on.

When the status of that test is being shown, the “Red LED” will be on.

To exit service test mode, wait 20 minutes or unplug the machine. If the control doesn’t respond getting to test mode, unplug the machine for 30 seconds, plug it back in and wait 10 seconds, and then try again.


TEST 04: Compressor and Condensor fan motor:
Press SW#5 until 04 is in the display. Line voltage is switched to the compressor and fan motor from the board. Display will show 01-ON or 02-OFF. Check if the compressor and fan are working. If not check for 120 VAC at the compressor.
 

bwenzel

Premium Member
Joined
Jun 4, 2019
Messages
2
Location
roseville
Thank you , the test shows code 1 . Fan is running but compressor is not . A while later the compressor starting running and then off again . I let the unit sit all day unplugged . Came home , plugged it back in , ran the test again and by mistake set for test 8 , the entire screen lit up and says refrigeration into is set off in red letters . I took a photo but unable to paste here . Maybe someone pushed a combo of buttons and turned the unit off ?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,764
Location
McMullen Valley, Arizona
To upload photos--->Just Click "Go Advanced" at the bottom right side of this Quick Reply editor that we type in, then you will see the MANAGE Attachments Button.

Jake
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,083
Location
Murray, Utah 84107, United States
Fan is running but compressor is not . A while later the compressor starting running and then off again.....
Sounds like the compressor is tripping the overload. Check the compressor windings and start device with your meter. Here's how to check the compressor:
R -Compressor Windings Test A.jpg

Your machine uses a start device. Here's how to check it:
R-OL-SD TEST.jpg
 
Top