• Please note, some of the links on our site are affiliate links (Learn More)
  • Important Announcement

    It's with sad news to announce that our site owner, Jake, has passed away. You can read the details here.

KSIB900ESS1 Whirlpool Range - Oven not heating


Premium Member
Apr 17, 2023
Model Number
6-10 years
I have a KSIB900ESS1 Induction Range we purchased new in 2017. Until last week, the oven worked great. However, while my wife was baking last week she experienced a coil burn out. I replaced the baking element and the oven still will not heat (either using bake, broil, convection or the bottom drawer.) When the oven is turned on, it shows it as preheating but it is not. There are no error messages that I can see, it is not locked/on delayed start etc.

After replacing the baking element and the oven still not working, I grabbed my multimeter and tested the temperature sensor (tested ok) and the thermal fuse (bad.) However, after replacing the thermal fuse the oven still will not heat. The induction top works as it should and all of the controls on top operate as one would expect.

Any ideas as to what the issue could be or what I could check next? Both elements check out with the multimeter too. Thanks in advance for your time and thoughts! -Chad
Hi Chad,

You replaced this thermal fuse?
Thermal Fuse WP3196548

You ohm tested the new thermal fuse and its good?

The only part left that would cause this issue is the oven control board: Cntrl-Elec W11100622

I'm attaching your wiring diagram below, the main bake element that gets its power from the oven control board from P2-3 to P15-1. Becareful not to touch anything else when testing live electricity.


  • wiring-sheet-W10903850-RevA.pdf
    278.6 KB · Views: 41

Thanks for your reply and wiring diagram, it is much appreciated! I did test both the old and new fuses. The old one was shot and was the reason I stopped and ordered that part after replacing the bad element. The new one checked out as being good. I was really hoping that the control board was not going to be bad. Is there some way the display on the actual stove will tell if there are issues or parts that are bad? If so, is there anything that can be shared about accessing this information?

Thanks again!
Yes, in Diagnostics Mode per your tech. data sheet, which I'm attaching below.


  • Tech+Sheet+-+W10665227+-+Rev+B (1).pdf
    178.7 KB · Views: 42
Your Welcome, let us know what you find if you could please.
Well, the saga continues. I received the part today but the new wiring harness which was included was broken.


  • PXL_20230420_184932523.jpg
    230.2 KB · Views: 31
Yes, I see that, just contact the place you got it from and they will send another new one.
OK, replacement part just arrived about an hour ago. I carefully installed everything, but things back together and powered up the unit. Now I am getting "Call Service - Stuck/Shorted Key F2E1" error code. I am about ready to throw this thing out in the yard and work it over like they did the printer in Office Space. Anyone have any thoughts?
I have unplugged the oven, waited 5 minutes and then plugged it back in. The F2E1 fault returns. This issue was not present before I replaced the board. Is there anything I can check with the new board? And would anyone know the correct part number for the keypad? Thanks!
That's very odd, you are absolutely sure you connected the wire harness properly, check for any bent pins or pins not aligning properly.

Here's the console touchpad assembly for your model: Panl-Cntrl W11034444
Jake, thanks again for your reply. It turns out after ordering the new control board assembly that the second wiring harness which came with the new control board was faulty. Go figure! I installed the original wiring harness to test things out as the unit kept showing the stuck key error. When I used the original wiring harness, the error went away.

Just out of curiosity, are there any issues to keep using the old wiring harness? It looks as though the new harness may have a built in fuse, which may prevent burn out damage to the control board like I originally experienced? Thanks again.
Just out of curiosity, are there any issues to keep using the old wiring harness?
Not that I'm aware of.

It looks as though the new harness may have a built in fuse, which may prevent burn out damage to the control board like I originally experienced?
Yes, I see that too.

The the oven control board comes with the new wire harness: Cntrl-Elec W11100622

All you can do is either use that original wire harness or contact the place where you got the oven control board and let them know the new wire harness is defective, and they should be able to send another one free of charge.
Well, I contacted the place which I purchased the control board from and they are out of stock and have refunded my money for the original control board. I am currently using the original wiring harness and there does not appear to be any issue in doing so.......EXCEPT the oven does not want to heat beyond 315 degrees. I have tried the boiler and this works, but when you select to use the oven and try to set the heat for 350 degrees the oven never makes it there. Any thoughts? When I was initially troubleshooting this whole thing, I tested all parts to include the temperature sensor. Any chance this would be the part causing the oven not to fully heat to a given setting? I also ran a diagnostic test and there were not any faults which appeared. Any assistance or advice would be greatly appreciated. Thanks!
Since the oven sensor ohms good, then it has to be the oven control board, that's all that controls the power to the bake element.

I see 1 in-stock here: Cntrl-Elec W11100622

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.