• Please note, some of the links on our site are affiliate links (Learn More)

KUDS01FLSS6 Kitchenaid Dishwasher Control Buttons Not working

jeehole

Premium Member
Joined
Nov 22, 2017
Messages
10
Location
Massachusetts
Model Number
KUDS01FLSS6
Brand
KitchenAid
Age
More than 10 years
Hello,
I have an older Kitchenaid KUDS01FLSS6 Dishwasher

None of the "Cycle" buttons are working on the control panel

1656015583466.png


The options button work, and the cancel button works. Start also doesn't seem to work. But that may be because I can't set the cycle.

There's some history with this DW - about 3 years ago the control board caught on fire. I replaced that and its been working since. The user interface board took some smoke damage but seemed ok.

I've also replaced the black plastic piece with the blister buttons a couple of years ago. They were cracked and water was getting into the buttons they would not work until dried with a fan. (could have led to my current problem)

I'm trying to determine if its the user interface board that's bad or the main board or something else like a sensor?

If I press the key sequence to run a test (hi temp, energy saver, hi temp, energy saver) all the lights light up and it runs through a test cycle.

ALSO I opened the panel and tried probing the terminals on the buttons with a continuity meter. Got some inconclusive results, but somehow in the process the normal cycle light lit up! Start button still didn't seem to do anything. But I put the panel back on and closed the door, and it ran a full cycle (and cleaned they dishes that were stuck in there YAY)

However the buttons still don't work.

Anyone have an opinion if a new user interface board will fix it? (My local shop has a rebuilt one for $65)

Thanks!
Joel
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Hi Joel,

It sounds like you have a corroded ribbon cable or your user interface board is bad.

First turn the breaker OFF to the dishwasher, then remove the ribbon cable and see if its corroded at the ends or has bad spots in it.

Here's the ribbon cable for your model:
WP8524447 Ribbon Cable


If the ribbon cable looks good, then the user interface board is the culprit.

Here's the user interface board for your model:
WP8270168 User Interface


Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top