• Please note, some of the links on our site are affiliate links (Learn More)

FIXED KUDS01FLSS6 KitchenAid Dishwasher not running, blinking lights

Status
Not open for further replies.

Sbrewer731

Premium Member
Joined
May 30, 2021
Messages
7
Location
Orange, Virginia
Model Number
KUDS01FLSS6
Brand
KitchenAid
Age
More than 10 years
So my heating element burnt out. Before it did I noticed it melting my silverware basket in one spot. Then the other day it ran a cycle but didn’t dry anything. Then the clean light was blinking 7 times. I tried to do that combo to reset. Crack door ajar, hit combo Hi temp/dry/hi temp/dry close door then immediately hit cancel.

Later I came back to it and the clean light is still blinking 7 times and also cancel is blinking and Normal is blinking.

So I ordered a new silverware tray, new element plus the nuts for it for install. Arrived today, husband installed after reviewing the video to show install. Everything is connected. Put back together. Hit the breaker to allow power.

7 blinking light STILL going. I tried the combo again. Now all those lights I mentioned are going off like a blinking Christmas tree again. 😑 help!!!!!
 

Sbrewer731

Premium Member
Joined
May 30, 2021
Messages
7
Location
Orange, Virginia
I will add that we purchased this dishwasher used and not working about 3 years ago. We replaced the fuse and the control panel and it has been working perfect since until now. Do you think I need to replace the control panel again? Or a fuse maybe? I feel like it could be the fuse bc of the heating element burning out. I just don’t want to waste money on parts I don’t need.
 

Attachments

  • D6F53D5E-7545-41F3-A365-70DD2116C14F.jpeg
    D6F53D5E-7545-41F3-A365-70DD2116C14F.jpeg
    335.3 KB · Views: 35

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,814
Location
McMullen Valley, Arizona
Don't hit cancel after you do that keypad dance.:)

Screenshot 2021-05-31 10.22.14.png


Then touch anything else, and let it run all the way through by-itself.

Jake
 

Sbrewer731

Premium Member
Joined
May 30, 2021
Messages
7
Location
Orange, Virginia
So I turned the breaker off and let it sit then turned it back on. It went back to just the 7x blinking clean. I did the above sequence. The buttons responded again as far as it lighting up when I hit them (they stopped responding when all the lights were blinking before). But I’m not noticing it doing anything as far as it doing a diagnostic cycle. The clean light still blinking though. I’m leaving it alone and will come back to it. But I’m guessing the blinking lights will probably all come on again and the bottoms won’t respond to anything when it does that.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,814
Location
McMullen Valley, Arizona
Ok, now it sounds like you have a corroded ribbon cable or your user interface board is bad.

First turn the breaker OFF to the dishwasher, then remove the ribbon cable and see if its corroded at the ends or has bad spots in it.

Here's the ribbon cable for your model:
WP8524447 Ribbon Cable


If the ribbon cable looks good, then the user interface board is the culprit.

Here's the user interface board for your model:
WP8270168 User Interface


Jake
 

Sbrewer731

Premium Member
Joined
May 30, 2021
Messages
7
Location
Orange, Virginia
Thank you for your help. We replaced both the ribbon and the user interface and it’s working perfectly! Looks like something got in and leaked on the user interface. It was sticky.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,814
Location
McMullen Valley, Arizona
Excellent, glad to hear the new ribbon and the user interface fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top