• Please note, some of the links on our site are affiliate links (Learn More)

KUIA15NLHS11 Ice maker Not making ice and screeching

FLEA

Premium Member
Joined
Jul 11, 2016
Messages
12
Location
Mississippi
Model Number
KUIA15NLHS
Brand
KitchenAid
Age
6-10 years
My ice maker is not making Ice like it should and then it will start screeching like a pump or motor is running dry....Not sure where to start or what to replace. I can turn it off for a while and back on and it seems to run ok but again little if any ice and the sound will return. I have cleaned the unit multiple times with cleaner. Any help would be appreciated.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,643
Location
Murray, Utah 84107, United States
OK, I'll need the serial number from the model tag. I need you to run a few quick tests for me.

First try this; Turn the machine off and remove power for longer than 60 seconds then restore power. The Flush Mode begins every time the pushbutton switch is changed to “On” from “Off”. Turn the machine on and check the following;

Water valve is energized for 2 minutes > recirculation pump is energized for 1 minutes > water valve is energized for 2 minutes.

The first 30 seconds of the clean cycle is the service cycle. *Check the following; Select clean. The control checks the bin thermistor and then the evaporator thermistor. If the bin thermistor is not sensed the clean LED will blink twice. If the evap thermistor is not sensed the clean LED blinks five times. After the thermistor check:

*Water valve on for 5 seconds > *Condensor fan on for 5 seconds > *Hot gas valve energized for 5 seconds > *Recirculation pump on for 5 seconds > *Compressor on for 5 seconds.

Clean cycle begins. Recirculation pump, compressor and hot gas valve are energized for 20 minutes. > *The water valve is energized for 3 minutes
 

FLEA

Premium Member
Joined
Jul 11, 2016
Messages
12
Location
Mississippi
Sorry for the delay...life happens. Any way, info as requested
ser#EU0815514
  • the CLEAN LED - light blinks continuously it never stopped once machine was turned on
  • I noticed the water reservoir was only filling 1/2 way maybe a little less.
  • still very low ice production
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,643
Location
Murray, Utah 84107, United States
I noticed the water reservoir was only filling 1/2 way maybe a little less.
How long was the water valve energized? Is that where the noise is?
 

FLEA

Premium Member
Joined
Jul 11, 2016
Messages
12
Location
Mississippi
The water ran for maybe 10 seconds or so. I would say Yes, the noise seems to be coming from that area. Very little ice production.
 

FLEA

Premium Member
Joined
Jul 11, 2016
Messages
12
Location
Mississippi
Part Ordered....Is the Valve located by the water reservoir or is this part located somewhere else....it looks like according to the schematic it is up top by the reservoir.
 
Top