• Please note, some of the links on our site are affiliate links (Learn More)

LG Bake element not receiving power

jones814

Premium Member
Joined
Sep 1, 2021
Messages
2
Location
89101
Model Number
LSWS305ST
Brand
LG
Age
1-5 years
I have an LG Studio Oven, LSWS305ST, that is not baking properly. Broil elements work fine, but bake element does not seem to be getting any electricity.
Test results:
ALL elements have about 22 ohms when tested for continuity
None of the thermal fuses are blown
The temperature probe continuity is within specs when tested (with ice water and boiling water)
Both broil elements receive 220VAC during pre-heat cycle
Bake element receives no voltage during preheat
Relay for bake element receives 220VAC but does not pass it to outbound wire to bake element
Control board (relay board) was replaced (EBR43297002) , with no change in tests
Main PCB assembly (main board) was replaced (EBR43296802) with no change.

Only additional info is that 3 or more rapid clicks can be heard on relay board when the oven is set to bake mode. This may be normal, I don't know.
 

Attachments

  • Main Board.jpg
    Main Board.jpg
    673.9 KB · Views: 22
  • relay board.jpg
    relay board.jpg
    307 KB · Views: 20
  • Oven.jpg
    Oven.jpg
    78.9 KB · Views: 20

jones814

Premium Member
Joined
Sep 1, 2021
Messages
2
Location
89101
I forgot to mention, the voltage test was at the bake element relay, not at the far end of the wire. The relay pole had 220VAC (one leg of the 220VAC) but the throw did not register and voltage while in bake mode).
 
Top