• Please note, some of the links on our site are affiliate links (Learn More)
  • Important Announcement

    It's with sad news to announce that our site owner, Jake, has passed away. You can read the details here.

LG LTC22350 Fridge light/freezer fan fail after 7 minutes


Premium Member
May 11, 2023
Model Number
6-10 years
LG LTC22350 Fridge - fridge light/evaporator (freezer) fan circuit fail after 7 minutes

This circuit fails after *7 minutes* the result of which is the fridge gets no cold airflow from the freezer making the fridge compartment unusable.

Freezer keeps cold.

New Parts: main board, refrigerator thermistor, OLP/PTC

Test mode 1 – everything works correctly.

Last thing not replaced (yet) is the run capacitor.

Is this the likely source of the problem (given the other new part changes) of that circuit switching off (with audible click) at 7 minutes from start?

Any other reason this could be happening?

All help is appreciated!
Here's the run capacitor for your model: 0CZZJB2014L

Its best to use a analog meter to ohm test any capacitor.

Look here:

Hi Jake,

Thanks for the video.

It turns out the run capacitor is not the issue. I replaced it with a new one and still get the same issue of the fridge light/evaporator (freezer) fan circuit failing after ~7 minutes.

All 3 of the thermistors are reading (measured by resistance on the main board) at higher temp than is actual in both the freezer and the fridge compartments.

The thermistor in the fridge is new and is still reading (hotter than actual) incorrectly…

Any idea as to what would cause all 3 to be reading hotter than they actually are and how is this correlated to the fridge light/thermistor/fan circuit switching off after ~7 minutes?

These are anomalies the test mode does not uncover.

Any idea what could be the remaining cause of this?

This is very unusual, I've never run across this problem before, you're already replaced the parts that should of fixed it.

Hopefully another tech or member that's seen this problem and fixed it can shed some light on this issue.
Yes it is, although i did find a couple of other forum post with people reporting the same kind of failure, but no one has resolved this issue.

So it remains unresolved afaik.

We are going to cut our losses and go to the store for a new one!


Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.