• Please note, some of the links on our site are affiliate links (Learn More)

FIXED LRE30451ST LG Range Oven Overheating

Status
Not open for further replies.

Bazski2003

Premium Member
Joined
Mar 5, 2018
Messages
2
Location
Upstate NY
Model Number
LRE30451ST
Brand
LG
Age
More than 10 years
Hello, My wife set the oven to 350 yesterday to bake cookies, preheat to 350 and beeped and cookies went in, a little bit later we smelled burning, cookies were black, broiler element seemed to remain on and stove was extremely hot. The stove still said 350 but was not cycling on/off and temp was over 500 degrees. Shut it down and it cooled off, stove was unplugged and took the back off, tried to test the temp probe, but pins of my ohm meter didn't fit in the connector. I see online how it could be a number of thing. Was wondering any way I could narrow it down, hoping to get another year or two out of it. I also saw while researching that this model and my serial was involved in a recall that I never had done.

Thanks for any help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,854
Location
McMullen Valley, Arizona
Hi,

I'd first ohm test your oven sensor, if your meter probes are too large, they make small adapters you could get.

You'd pull the Range out from the wall, then unplug it, then remove the back access panel, then you will see the little electrical connector that snaps to it, then unsnap it and ohm test the oven sensor part only.

Here's the oven sensor for your model:
Temperature Sensor 6322B62214A



If the oven sensor ohm tests good, then its possibly the relay board that controls the on/off cycle of the heating element inside the oven.

Here's the relay board for your model:
Relay Board 6871W1N012B


Jake
 

Bazski2003

Premium Member
Joined
Mar 5, 2018
Messages
2
Location
Upstate NY
Thanks so much Jake, it ended up being the relay board, replaced and back in business. Saved me from buying a new stove, much appreciated!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,854
Location
McMullen Valley, Arizona
Excellent, glad to hear the new relay board fixed it.:)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top